karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marko Herchet (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-5217) client.bat not working when passwords are encrypted
Date Fri, 23 Jun 2017 09:24:00 GMT
Marko Herchet created KARAF-5217:
------------------------------------

             Summary: client.bat not working when passwords are encrypted
                 Key: KARAF-5217
                 URL: https://issues.apache.org/jira/browse/KARAF-5217
             Project: Karaf
          Issue Type: Bug
          Components: karaf-shell
    Affects Versions: 4.1.1
            Reporter: Marko Herchet


When using the bin\client.bat without specifying a user, org.apache.karaf.client.ClientConfig
determines username + password by parsing the etc\users.properties and using the first user
+ pw.

When I set "encryption.enabled = false" in org.apache.karaf.jaas.cfg, my users.properties
looks like this:
{code}
karafuser = anypw,admin
{code}
it works and the shell opens.

When I set "encryption.enabled = false" in org.apache.karaf.jaas.cfg, my users.properties
looks like this:
{code}
karafuser = {CRYPT}8FEF7493AC1C5A5EC2D1C051576DEF6B32E1D834302DC46C396F325C82214DF3{CRYPT},admin
{code}
I get the following LogEntry and it prompts for password
1094 [sshd-SshClient[1afa04c]-nio2-thread-4] TRACE org.apache.sshd.client.session.ClientSessionImpl
- doHandleMessage(ClientSessionImpl[karafuser@localhost/127.0.0.1:8101]) process SSH_MSG_USERAUTH_FAILURE




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message