karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Winnall (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (KARAF-5110) Karaf 4.1.x / httplite incompatibility
Date Thu, 27 Apr 2017 14:21:04 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5110?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15986704#comment-15986704
] 

Stephen Winnall edited comment on KARAF-5110 at 4/27/17 2:20 PM:
-----------------------------------------------------------------

The attachment contains a minimal subset of my project which illustrates the issue:

1) unpack
2) build
3) run
4) log:display

You'll see the error message

2017-04-27 16:19:04,335 | ERROR | FelixStartLevel  | Felix                            |  -
 -  | Bundle org.ops4j.pax.web.pax-web-extender-whiteboard [118] Error starting mvn:org.ops4j.pax.web/pax-web-extender-whiteboard/6.0.3
(org.osgi.framework.BundleException: Activator start error in bundle org.ops4j.pax.web.pax-web-extender-whiteboard
[118].)
org.osgi.framework.BundleException: Activator start error in bundle org.ops4j.pax.web.pax-web-extender-whiteboard
[118].
	at org.apache.felix.framework.Felix.activateBundle(Felix.java:2288) [?:?]
	at org.apache.felix.framework.Felix.startBundle(Felix.java:2144) [?:?]
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) [?:?]
	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
[?:?]
	at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: java.lang.ClassCastException: org.apache.felix.httplite.osgi.HttpServiceImpl cannot
be cast to org.osgi.service.http.HttpService
...


was (Author: winnall):
This contains a minimal subset of my project which illustrates the issue:

1) unpack
2) build
3) run
4) log:display

You'll see the error message

2017-04-27 16:19:04,335 | ERROR | FelixStartLevel  | Felix                            |  -
 -  | Bundle org.ops4j.pax.web.pax-web-extender-whiteboard [118] Error starting mvn:org.ops4j.pax.web/pax-web-extender-whiteboard/6.0.3
(org.osgi.framework.BundleException: Activator start error in bundle org.ops4j.pax.web.pax-web-extender-whiteboard
[118].)
org.osgi.framework.BundleException: Activator start error in bundle org.ops4j.pax.web.pax-web-extender-whiteboard
[118].
	at org.apache.felix.framework.Felix.activateBundle(Felix.java:2288) [?:?]
	at org.apache.felix.framework.Felix.startBundle(Felix.java:2144) [?:?]
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371) [?:?]
	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
[?:?]
	at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: java.lang.ClassCastException: org.apache.felix.httplite.osgi.HttpServiceImpl cannot
be cast to org.osgi.service.http.HttpService
...

> Karaf 4.1.x / httplite incompatibility
> --------------------------------------
>
>                 Key: KARAF-5110
>                 URL: https://issues.apache.org/jira/browse/KARAF-5110
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.1.1
>         Environment: Maven 3.3.9 / MacOS 10.12.4
>            Reporter: Stephen Winnall
>         Attachments: karaf-4.1.x-httplite.tbz
>
>
> I am trying to build a Karaf assembly using Karaf 4.1.1, Java 1.8.0_76-ea-b04, Maven
3.3.9, Netbeans 8.2 and macOS 10.12.4. I am getting an error message, even if I omit all my
own features from the build (i.e. I build an empty Karaf): 
>     java.lang.ClassCastException: org.apache.felix.httplite.osgi.HttpServiceImpl cannot
be cast to org.osgi.service.http.HttpService 
> The problem seems to be that the latest version of org.apache.felix.httplite.complete,
which provides org.apache.felix.httplite.osgi.HttpServiceImpl, i.e. 0.1.5, requires a version
of java.servlet that is incompatible with the rest of Karaf 4.1.1, which - I think - expects
3.1.0. The following comes from the MANIFEST.MF of org.apache.felix.httplite.complete-0.1.5.jar:

>     Import-Package: javax.servlet;version="[2.4,3)" 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message