karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Offenbach (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-5051) Command "shell wrapper:install" fails
Date Tue, 21 Mar 2017 14:29:41 GMT
Jens Offenbach created KARAF-5051:
-------------------------------------

             Summary: Command "shell wrapper:install" fails
                 Key: KARAF-5051
                 URL: https://issues.apache.org/jira/browse/KARAF-5051
             Project: Karaf
          Issue Type: Bug
          Components: karaf-shell
    Affects Versions: 4.1.1
            Reporter: Jens Offenbach


I am currently using {{apache-karaf-4.1.1-20170320.164246-38.tar.gz}} on Ubuntu 16.04 LTS
and the following command fails:

{code}
$ shell wrapper:install --start-type DEMAND_START
[org.apache.karaf.shell.support.ShellUtil] : Command exception (Undefined option, ...)
org.apache.karaf.shell.support.CommandException: Too many arguments specified
        at org.apache.karaf.shell.impl.action.command.DefaultActionPreparator.prepare(DefaultActionPreparator.java:160)
        at org.apache.karaf.shell.impl.action.command.ActionCommand.execute(ActionCommand.java:83)
        at org.apache.karaf.shell.impl.console.CommandWrapper.execute(CommandWrapper.java:53)
        at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:560)
        at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:486)
        at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:375)
        at org.apache.felix.gogo.runtime.Pipe.doCall(Pipe.java:417)
        at org.apache.felix.gogo.runtime.Pipe.call(Pipe.java:229)
        at org.apache.felix.gogo.runtime.Pipe.call(Pipe.java:59)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Error executing command wrapper:install: too many arguments specified
{code}

May someone please have a look.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message