karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-5007) karaf:run doesn't work due to resolver upgrade
Date Mon, 06 Mar 2017 10:07:33 GMT

    [ https://issues.apache.org/jira/browse/KARAF-5007?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15897016#comment-15897016
] 

Jean-Baptiste Onofré commented on KARAF-5007:
---------------------------------------------

OK, found the issue: the {{karaf-maven-plugin}} expects to have {{<karafDistribution/>}}
to at least {{4.0.9-SNAPSHOT}} in order to have the right alignment between framework and
resolver. Fixing.

> karaf:run doesn't work due to resolver upgrade
> ----------------------------------------------
>
>                 Key: KARAF-5007
>                 URL: https://issues.apache.org/jira/browse/KARAF-5007
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-tooling
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>            Priority: Blocker
>             Fix For: 4.0.9
>
>
> The {{karaf-run}} IT fails due to abstract method error:
> {code}
> INFO: Lock acquired. Setting startlevel to 100
> ERROR: Bundle org.apache.felix.metatype [5] Error starting mvn:org.apache.felix/org.apache.felix.metatype/1.1.2
(java.lang.AbstractMethodError: org.apache.felix.framework.ResolveContextImpl.getSubstitutionWires(Lorg/osgi/resource/Wiring;)Ljava/util/Collection;)
> java.lang.AbstractMethodError: org.apache.felix.framework.ResolveContextImpl.getSubstitutionWires(Lorg/osgi/resource/Wiring;)Ljava/util/Collection;
>         at org.apache.felix.resolver.ResolverImpl.calculateExportedPackages(ResolverImpl.java:1613)
>         at org.apache.felix.resolver.ResolverImpl.access$200(ResolverImpl.java:33)
>         at org.apache.felix.resolver.ResolverImpl$3.run(ResolverImpl.java:1152)
>         at org.apache.felix.resolver.ResolverImpl$EnhancedExecutor$1.run(ResolverImpl.java:2473)
>         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
>         at java.lang.Thread.run(Thread.java:745)
> ERROR: Bundle org.apache.karaf.services.eventadmin [6] Error starting mvn:org.apache.karaf.services/org.apache.karaf.services.eventadmin/4.0.8
(java.lang.AbstractMethodError: org.apache.felix.framework.ResolveContextImpl.getSubstitutionWires(Lorg/osgi/resource/Wiring;)Ljava/util/Collection;)
> ...
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message