karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xilai Dai (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KARAF-4811) The wrong version jetty feature will be installed when install camel-jetty9 feature
Date Tue, 01 Nov 2016 07:59:59 GMT

     [ https://issues.apache.org/jira/browse/KARAF-4811?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Xilai Dai updated KARAF-4811:
-----------------------------
    Description: 
Start karaf 4.0.5 console, execute the command: feature:install webconsole
Then the Jetty 9 bundles got installed.

Then try to install camel-jetty9 feature:
feature:repo-add mvn:org.apache.camel.karaf/apache-camel/2.16.3/xml/features
feature:install camel-core
feature:install -v camel-jetty9

{code}
karaf@root()> feature:install -v camel-jetty9
Adding features: camel-jetty9/[2.16.3,2.16.3]
Changes to perform:
  Region: root
    Bundles to update:
      javax.mail/1.4.4 with mvn:javax.mail/mail/1.4.5
    Bundles to install:
      mvn:org.apache.camel/camel-http-common/2.16.3
      mvn:org.apache.camel/camel-jetty-common/2.16.3
      mvn:org.apache.camel/camel-jetty9/2.16.3
Stopping bundles:
  javax.mail/1.4.4
Updating bundles:
  mvn:javax.mail/mail/1.4.5
Installing bundles:
  mvn:org.apache.camel/camel-http-common/2.16.3
  mvn:org.apache.camel/camel-jetty-common/2.16.3
  mvn:org.apache.camel/camel-jetty9/2.16.3
Stopping bundles:
  javax.mail/1.4.5
  org.eclipse.jetty.plus/9.2.15.v20160210
  org.eclipse.jetty.jndi/9.2.15.v20160210
  org.ops4j.pax.logging.pax-logging-service/1.8.5
Refreshing bundles:
    javax.mail/1.4.5 (Bundle will be updated)
    org.eclipse.jetty.jndi/9.2.15.v20160210 (Wired to javax.mail/1.4.4 which is being refreshed)
    org.eclipse.jetty.plus/9.2.15.v20160210 (Wired to org.eclipse.jetty.jndi/9.2.15.v20160210
which is being refreshed)
    org.ops4j.pax.logging.pax-logging-service/1.8.5 (Wired to javax.mail/1.4.4 which is being
refreshed)
Starting bundles:
  org.ops4j.pax.logging.pax-logging-service/1.8.5
  org.eclipse.jetty.jndi/9.2.15.v20160210
  org.eclipse.jetty.plus/9.2.15.v20160210
  javax.mail/1.4.5
  org.apache.camel.camel-http-common/2.16.3
  org.apache.camel.camel-jetty-common/2.16.3
  org.apache.camel.camel-jetty9/2.16.3
Done.
karaf@root()>
{code}

The javax.mail is updated from 1.4.4 to 1.4.5 unexpectedly. 

the camel-jetty9 feature:
{code}
  <feature name='camel-jetty9' version='2.16.3' resolver='(obr)' start-level='50'>
    <details>camel-jetty9 intend to work with jetty9, so this feature only works in
the karaf container which support jetty9, e.g. karaf 4.x</details>
    <feature>jetty</feature>
    <feature version='2.16.3'>camel-core</feature>
    <bundle>mvn:org.apache.camel/camel-http-common/2.16.3</bundle>
    <bundle>mvn:org.apache.camel/camel-jetty-common/2.16.3</bundle>
    <bundle>mvn:org.apache.camel/camel-jetty9/2.16.3</bundle>
  </feature>
{code}

the jetty 8 feature:
{code}
    <feature name="jetty" version="8.1.14.v20131031">
        <bundle start-level="30" dependency="true">mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.activation-api-1.1/2.7.0</bundle>
        <bundle start-level="30" dependency="true">mvn:javax.servlet/javax.servlet-api/3.1.0</bundle>
        <bundle start-level="30" dependency="true">mvn:javax.mail/mail/1.4.5</bundle>
        <bundle start-level="30" dependency="true">mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1</bundle>
        <bundle start-level="30" dependency="true">mvn:org.apache.geronimo.specs/geronimo-annotation_1.1_spec/1.0.1</bundle>
        <bundle start-level="30" dependency="true">mvn:org.apache.geronimo.specs/geronimo-jaspic_1.0_spec/1.1</bundle>
        <bundle start-level="30">mvn:org.eclipse.jetty.aggregate/jetty-all-server/8.1.14.v20131031</bundle>
    </feature>
{code}

If I remove the jetty/8.1.14.v20131031 feature from the standard-4.0.5-features.xml, or claim
require jetty 9 explicitly ( {code}<feature version='[9.2,10)'>jetty</feature>{code}),
then it works as expected.

  was:
Start karaf 4.0.5 console, execute the commands:
feature:repo-add mvn:org.apache.camel.karaf/apache-camel/2.16.3/xml/features
feature:install -v camel-jetty9

{code}
karaf@root()> feature:install -v camel-jetty9
Adding features: camel-jetty9/[2.16.3,2.16.3]
Changes to perform:
  Region: root
    Bundles to install:
      mvn:javax.mail/mail/1.4.5
      mvn:javax.servlet/javax.servlet-api/3.1.0
      mvn:javax.websocket/javax.websocket-api/1.1
      mvn:org.apache.aries.spifly/org.apache.aries.spifly.dynamic.bundle/1.0.1
      mvn:org.apache.camel/camel-catalog/2.16.3
      mvn:org.apache.camel/camel-commands-core/2.16.3
      mvn:org.apache.camel/camel-core/2.16.3
      mvn:org.apache.camel/camel-http-common/2.16.3
      mvn:org.apache.camel/camel-jetty-common/2.16.3
      mvn:org.apache.camel/camel-jetty9/2.16.3
      mvn:org.apache.camel.karaf/camel-karaf-commands/2.16.3
      mvn:org.apache.geronimo.specs/geronimo-jaspic_1.0_spec/1.1
      mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jaxb-impl/2.2.6_1
      mvn:org.eclipse.jetty/jetty-client/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-continuation/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-http/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-io/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-jaas/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-jaspi/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-jmx/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-jndi/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-plus/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-rewrite/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-security/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-server/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-servlet/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-servlets/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-util/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-util-ajax/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-webapp/9.2.15.v20160210
      mvn:org.eclipse.jetty.websocket/websocket-api/9.2.15.v20160210
      mvn:org.eclipse.jetty.websocket/websocket-client/9.2.15.v20160210
      mvn:org.eclipse.jetty.websocket/websocket-common/9.2.15.v20160210
      mvn:org.eclipse.jetty.websocket/javax-websocket-client-impl/9.2.15.v20160210
      mvn:org.eclipse.jetty.websocket/javax-websocket-server-impl/9.2.15.v20160210
      mvn:org.eclipse.jetty.websocket/websocket-server/9.2.15.v20160210
      mvn:org.eclipse.jetty.websocket/websocket-servlet/9.2.15.v20160210
      mvn:org.eclipse.jetty/jetty-xml/9.2.15.v20160210
      mvn:org.codehaus.woodstox/stax2-api/3.1.4
      mvn:org.codehaus.woodstox/woodstox-core-asl/4.4.1
Installing bundles:
  mvn:javax.mail/mail/1.4.5
  mvn:javax.servlet/javax.servlet-api/3.1.0
  mvn:javax.websocket/javax.websocket-api/1.1
  mvn:org.apache.aries.spifly/org.apache.aries.spifly.dynamic.bundle/1.0.1
  mvn:org.apache.camel/camel-catalog/2.16.3
  mvn:org.apache.camel/camel-commands-core/2.16.3
  mvn:org.apache.camel/camel-core/2.16.3
  mvn:org.apache.camel/camel-http-common/2.16.3
  mvn:org.apache.camel/camel-jetty-common/2.16.3
  mvn:org.apache.camel/camel-jetty9/2.16.3
  mvn:org.apache.camel.karaf/camel-karaf-commands/2.16.3
  mvn:org.apache.geronimo.specs/geronimo-jaspic_1.0_spec/1.1
  mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
  mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jaxb-impl/2.2.6_1
  mvn:org.eclipse.jetty/jetty-client/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-continuation/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-http/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-io/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-jaas/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-jaspi/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-jmx/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-jndi/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-plus/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-rewrite/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-security/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-server/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-servlet/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-servlets/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-util/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-util-ajax/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-webapp/9.2.15.v20160210
  mvn:org.eclipse.jetty.websocket/websocket-api/9.2.15.v20160210
  mvn:org.eclipse.jetty.websocket/websocket-client/9.2.15.v20160210
  mvn:org.eclipse.jetty.websocket/websocket-common/9.2.15.v20160210
  mvn:org.eclipse.jetty.websocket/javax-websocket-client-impl/9.2.15.v20160210
  mvn:org.eclipse.jetty.websocket/javax-websocket-server-impl/9.2.15.v20160210
  mvn:org.eclipse.jetty.websocket/websocket-server/9.2.15.v20160210
  mvn:org.eclipse.jetty.websocket/websocket-servlet/9.2.15.v20160210
  mvn:org.eclipse.jetty/jetty-xml/9.2.15.v20160210
  mvn:org.codehaus.woodstox/stax2-api/3.1.4
  mvn:org.codehaus.woodstox/woodstox-core-asl/4.4.1
Stopping bundles:
  org.ops4j.pax.logging.pax-logging-service/1.8.5
Refreshing bundles:
    org.ops4j.pax.logging.pax-logging-service/1.8.5 (Should be wired to: javax.mail/1.4.5
(through [org.ops4j.pax.loggin
g.pax-logging-service/1.8.5] osgi.wiring.package; filter:="(osgi.wiring.package=javax.mail)";
resolution:=optional))
Starting bundles:
  org.ops4j.pax.logging.pax-logging-service/1.8.5
  stax2-api/3.1.4
  woodstox-core-asl/4.4.1
  org.apache.servicemix.bundles.jaxb-impl/2.2.6.1
  javax.servlet-api/3.1.0
  org.eclipse.jetty.util/9.2.15.v20160210
  org.eclipse.jetty.http/9.2.15.v20160210
  org.eclipse.jetty.io/9.2.15.v20160210
  org.eclipse.jetty.client/9.2.15.v20160210
  org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
  org.eclipse.jetty.jmx/9.2.15.v20160210
  org.eclipse.jetty.server/9.2.15.v20160210
  org.eclipse.jetty.security/9.2.15.v20160210
  org.eclipse.jetty.websocket.api/9.2.15.v20160210
  org.eclipse.jetty.websocket.common/9.2.15.v20160210
  org.apache.geronimo.specs.geronimo-jaspic_1.0_spec/1.1.0
  org.eclipse.jetty.jaspi/9.2.15.v20160210
  org.eclipse.jetty.servlet/9.2.15.v20160210
  org.apache.aries.spifly.dynamic.bundle/1.0.1
  org.eclipse.jetty.websocket.servlet/9.2.15.v20160210
  org.eclipse.jetty.websocket.server/9.2.15.v20160210
  javax.websocket-api/1.1.0
  org.eclipse.jetty.websocket.client/9.2.15.v20160210
  org.eclipse.jetty.websocket.javax.websocket/9.2.15.v20160210
  org.eclipse.jetty.rewrite/9.2.15.v20160210
  org.eclipse.jetty.websocket.javax.websocket.server/9.2.15.v20160210
  org.eclipse.jetty.servlets/9.2.15.v20160210
  org.eclipse.jetty.util.ajax/9.2.15.v20160210
  org.eclipse.jetty.xml/9.2.15.v20160210
  org.eclipse.jetty.webapp/9.2.15.v20160210
  org.eclipse.jetty.plus/9.2.15.v20160210
  org.eclipse.jetty.jaas/9.2.15.v20160210
  org.eclipse.jetty.continuation/9.2.15.v20160210
  javax.mail/1.4.5
  org.eclipse.jetty.jndi/9.2.15.v20160210
  org.apache.camel.camel-core/2.16.3
  org.apache.camel.camel-http-common/2.16.3
  org.apache.camel.camel-jetty-common/2.16.3
  org.apache.camel.camel-catalog/2.16.3
  org.apache.camel.camel-jetty9/2.16.3
  org.apache.camel.camel-commands-core/2.16.3
  org.apache.camel.karaf.camel-karaf-commands/2.16.3
Done.
karaf@root()>
{code}

The jetty feature version 8 will be installed, not the jetty 9 feature which defined in the
standard-4.0.5-features.xml. 

the camel-jetty9 feature is defined as below:
{code}
  <feature name='camel-jetty9' version='2.16.3' resolver='(obr)' start-level='50'>
    <details>camel-jetty9 intend to work with jetty9, so this feature only works in
the karaf container which support jetty9, e.g. karaf 4.x</details>
    <feature>jetty</feature>
    <feature version='2.16.3'>camel-core</feature>
    <bundle>mvn:org.apache.camel/camel-http-common/2.16.3</bundle>
    <bundle>mvn:org.apache.camel/camel-jetty-common/2.16.3</bundle>
    <bundle>mvn:org.apache.camel/camel-jetty9/2.16.3</bundle>
  </feature>
{code}

It doesn't not claim the jetty version 9 feature explicitly, but karaf should install the
most latest version 9 in this case.

If I remove the jetty/8.1.14.v20131031 feature from the standard-4.0.5-features.xml, or claim
require jetty 9 explicitly ( {code}<feature version='[9.2,10)'>jetty</feature>{code}),
then it works as expected.


> The wrong version jetty feature will be installed when install camel-jetty9 feature
> -----------------------------------------------------------------------------------
>
>                 Key: KARAF-4811
>                 URL: https://issues.apache.org/jira/browse/KARAF-4811
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 4.0.5
>         Environment: Java 8
>            Reporter: Xilai Dai
>
> Start karaf 4.0.5 console, execute the command: feature:install webconsole
> Then the Jetty 9 bundles got installed.
> Then try to install camel-jetty9 feature:
> feature:repo-add mvn:org.apache.camel.karaf/apache-camel/2.16.3/xml/features
> feature:install camel-core
> feature:install -v camel-jetty9
> {code}
> karaf@root()> feature:install -v camel-jetty9
> Adding features: camel-jetty9/[2.16.3,2.16.3]
> Changes to perform:
>   Region: root
>     Bundles to update:
>       javax.mail/1.4.4 with mvn:javax.mail/mail/1.4.5
>     Bundles to install:
>       mvn:org.apache.camel/camel-http-common/2.16.3
>       mvn:org.apache.camel/camel-jetty-common/2.16.3
>       mvn:org.apache.camel/camel-jetty9/2.16.3
> Stopping bundles:
>   javax.mail/1.4.4
> Updating bundles:
>   mvn:javax.mail/mail/1.4.5
> Installing bundles:
>   mvn:org.apache.camel/camel-http-common/2.16.3
>   mvn:org.apache.camel/camel-jetty-common/2.16.3
>   mvn:org.apache.camel/camel-jetty9/2.16.3
> Stopping bundles:
>   javax.mail/1.4.5
>   org.eclipse.jetty.plus/9.2.15.v20160210
>   org.eclipse.jetty.jndi/9.2.15.v20160210
>   org.ops4j.pax.logging.pax-logging-service/1.8.5
> Refreshing bundles:
>     javax.mail/1.4.5 (Bundle will be updated)
>     org.eclipse.jetty.jndi/9.2.15.v20160210 (Wired to javax.mail/1.4.4 which is being
refreshed)
>     org.eclipse.jetty.plus/9.2.15.v20160210 (Wired to org.eclipse.jetty.jndi/9.2.15.v20160210
which is being refreshed)
>     org.ops4j.pax.logging.pax-logging-service/1.8.5 (Wired to javax.mail/1.4.4 which
is being refreshed)
> Starting bundles:
>   org.ops4j.pax.logging.pax-logging-service/1.8.5
>   org.eclipse.jetty.jndi/9.2.15.v20160210
>   org.eclipse.jetty.plus/9.2.15.v20160210
>   javax.mail/1.4.5
>   org.apache.camel.camel-http-common/2.16.3
>   org.apache.camel.camel-jetty-common/2.16.3
>   org.apache.camel.camel-jetty9/2.16.3
> Done.
> karaf@root()>
> {code}
> The javax.mail is updated from 1.4.4 to 1.4.5 unexpectedly. 
> the camel-jetty9 feature:
> {code}
>   <feature name='camel-jetty9' version='2.16.3' resolver='(obr)' start-level='50'>
>     <details>camel-jetty9 intend to work with jetty9, so this feature only works
in the karaf container which support jetty9, e.g. karaf 4.x</details>
>     <feature>jetty</feature>
>     <feature version='2.16.3'>camel-core</feature>
>     <bundle>mvn:org.apache.camel/camel-http-common/2.16.3</bundle>
>     <bundle>mvn:org.apache.camel/camel-jetty-common/2.16.3</bundle>
>     <bundle>mvn:org.apache.camel/camel-jetty9/2.16.3</bundle>
>   </feature>
> {code}
> the jetty 8 feature:
> {code}
>     <feature name="jetty" version="8.1.14.v20131031">
>         <bundle start-level="30" dependency="true">mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.activation-api-1.1/2.7.0</bundle>
>         <bundle start-level="30" dependency="true">mvn:javax.servlet/javax.servlet-api/3.1.0</bundle>
>         <bundle start-level="30" dependency="true">mvn:javax.mail/mail/1.4.5</bundle>
>         <bundle start-level="30" dependency="true">mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1</bundle>
>         <bundle start-level="30" dependency="true">mvn:org.apache.geronimo.specs/geronimo-annotation_1.1_spec/1.0.1</bundle>
>         <bundle start-level="30" dependency="true">mvn:org.apache.geronimo.specs/geronimo-jaspic_1.0_spec/1.1</bundle>
>         <bundle start-level="30">mvn:org.eclipse.jetty.aggregate/jetty-all-server/8.1.14.v20131031</bundle>
>     </feature>
> {code}
> If I remove the jetty/8.1.14.v20131031 feature from the standard-4.0.5-features.xml,
or claim require jetty 9 explicitly ( {code}<feature version='[9.2,10)'>jetty</feature>{code}),
then it works as expected.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message