karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4695) Unable to use http://karaf.apache.org/xmlns/shell/v1.0.0
Date Wed, 19 Oct 2016 13:20:58 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4695?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15588754#comment-15588754
] 

ASF subversion and git services commented on KARAF-4695:
--------------------------------------------------------

Commit 1d230955bd47c5b00880b105e8a20888b73d76f7 in karaf's branch refs/heads/karaf-4.0.x from
[~gnt]
[ https://git-wip-us.apache.org/repos/asf?p=karaf.git;h=1d23095 ]

[KARAF-4786][KARAF-4695] Upgrade to Aries Blueprint Core 1.7.1

> Unable to use http://karaf.apache.org/xmlns/shell/v1.0.0
> --------------------------------------------------------
>
>                 Key: KARAF-4695
>                 URL: https://issues.apache.org/jira/browse/KARAF-4695
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-shell
>    Affects Versions: 4.0.5, 4.0.6
>            Reporter: Kevin O'Toole
>
> Within my Blueprint file, if I use the http://karaf.apache.org/xmlns/shell/v1.0.0 namespace,
I get the following exception (notice it refers to 1.1.0 even though I am using 1.0.0)
> {noformat}org.xml.sax.SAXParseException: src-import.3.1: The namespace attribute, 'http://schemas.xmlsoap.org/wsdl/',
of an  element information item must be identical to the targetNamespace attribute, 'http://karaf.apache.org/xmlns/shell/v1.1.0',
of the imported document.
> 	at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown Source)[:]
> 	at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)[:]
> 	at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.traversers.XSDHandler.reportSchemaError(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.traversers.XSDHandler.reportSchemaError(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.traversers.XSDHandler.constructTrees(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.traversers.XSDHandler.constructTrees(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.traversers.XSDHandler.constructTrees(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.traversers.XSDHandler.parseSchema(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.XMLSchemaLoader.loadSchema(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar(Unknown Source)[:]
> 	at org.apache.xerces.impl.xs.XMLSchemaLoader.loadGrammar(Unknown Source)[:]
> 	at org.apache.xerces.jaxp.validation.XMLSchemaFactory.newSchema(Unknown Source)[:]
> 	at org.apache.aries.blueprint.namespace.NamespaceHandlerRegistryImpl$NamespaceHandlerSetImpl.createSchema(NamespaceHandlerRegistryImpl.java:641)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.namespace.NamespaceHandlerRegistryImpl$NamespaceHandlerSetImpl.doGetSchema(NamespaceHandlerRegistryImpl.java:458)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.namespace.NamespaceHandlerRegistryImpl$NamespaceHandlerSetImpl.getSchema(NamespaceHandlerRegistryImpl.java:443)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:343)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:276)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:300)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:269)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:265)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.blueprint.container.BlueprintExtender.modifiedBundle(BlueprintExtender.java:255)[48:org.apache.aries.blueprint.core:1.6.2]
> 	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:500)[66:org.apache.aries.util:1.1.1]
> 	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:433)[66:org.apache.aries.util:1.1.1]
> 	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.track(BundleHookBundleTracker.java:725)[66:org.apache.aries.util:1.1.1]
> 	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.bundleChanged(BundleHookBundleTracker.java:463)[66:org.apache.aries.util:1.1.1]
> 	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$BundleEventHook.event(BundleHookBundleTracker.java:422)[66:org.apache.aries.util:1.1.1]
> 	at org.apache.felix.framework.util.SecureAction.invokeBundleEventHook(SecureAction.java:1179)[org.apache.felix.framework-5.4.0.jar:]
> 	at org.apache.felix.framework.util.EventDispatcher.createWhitelistFromHooks(EventDispatcher.java:731)[org.apache.felix.framework-5.4.0.jar:]
> 	at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:486)[org.apache.felix.framework-5.4.0.jar:]
> 	at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4541)[org.apache.felix.framework-5.4.0.jar:]
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:2172)[org.apache.felix.framework-5.4.0.jar:]
> 	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)[org.apache.felix.framework-5.4.0.jar:]
> 	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)[org.apache.felix.framework-5.4.0.jar:]
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:1286)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:846)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1176)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1074)[8:org.apache.karaf.features.core:4.0.6]{noformat}
> I was able to update the Blueprint file to use http://karaf.apache.org/xmlns/shell/v1.1.0
as a permanent solution, but according to https://karaf.apache.org/manual/latest/#_namespaces,
the 1.0.0 namespace is still supported. I have a large number of projects that I would need
to update to support this. It appears this broke starting with Karaf 4.0.5.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message