karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Durand (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4592) Upgrade to Aries JDBC Transaction 2.1.2
Date Wed, 19 Oct 2016 13:14:58 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4592?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15588741#comment-15588741
] 

Marc Durand commented on KARAF-4592:
------------------------------------

[~jb@nanthrax.net], does the change made in this issue have any impact?  The value of <aries.transaction.jdbc.version>2.1.2</aries.transaction.jdbc.version>
in karaf/pom.xml is not used anywhere else in the karaf pom files.  Karaf 4.0.7 and 4.0.8-SNAPSHOT
both pull in org.apache.aries.transaction.jdbc-2.1.0.jar, which is installed when adding the
pax-jdbc-pool-aries feature (because PAX-JDBC 0.9.0 uses version 2.1.0).  So to upgrade to
2.1.2, it seems like a change is needed in PAX-JDBC and Karaf needs to upgrade to that new
version of PAX-JDBC.  Does this make sense, or am I missing something?

Thanks!
Marc

> Upgrade to Aries JDBC Transaction 2.1.2
> ---------------------------------------
>
>                 Key: KARAF-4592
>                 URL: https://issues.apache.org/jira/browse/KARAF-4592
>             Project: Karaf
>          Issue Type: Dependency upgrade
>          Components: karaf-core
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.1.0, 4.0.6
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message