karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amichai Rothman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-3973) Bundles refresh doesn't work (bundles not resolved)
Date Fri, 21 Oct 2016 00:40:58 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3973?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15593516#comment-15593516
] 

Amichai Rothman commented on KARAF-3973:
----------------------------------------

I'm on 4.0.4, and this still happens consistently - we have to restart our application once
after a fresh installation for it to work. We'll probably upgrade to a newer Karaf sometime
soon, and see if it still occurs.

I tried to provide full details, stack trace and logs above... if there is any other info
that might be helpful, let me know and I'll try to provide it.


> Bundles refresh doesn't work (bundles not resolved)
> ---------------------------------------------------
>
>                 Key: KARAF-3973
>                 URL: https://issues.apache.org/jira/browse/KARAF-3973
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>    Affects Versions: 4.0.1
>            Reporter: Amichai Rothman
>            Priority: Critical
>
> I have a bunch of bundles copied into the deploy folder of a fresh karaf 4.0.1 installation.
The first time karaf runs, the bundles are not properly resolved, and apparently this has
to do with the order in which they are loaded, i.e. if A depends on B and A is loaded first,
then when B is loaded it is properly resolved but A never gets resolved. running the refresh
command from console does not help either. However, if karaf itself is restarted, then everything
is resolved and activated with no problem.
> In Karaf up to 3.0.3 this was not an issue - the moment B was loaded, even on the first
time Karaf is run, A would automatically get resolved/activated as well. on 3.0.4 I get a
deadlock on startup, so can't really tell if it works (see KARAF-3941). on 4.0.0 I haven't
tried. 4.0.1 is the current reported issue.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message