karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paolo Antinori (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KARAF-4692) Inconsistent behavior towards Bundle-ManifestVersion
Date Fri, 02 Sep 2016 08:46:20 GMT

     [ https://issues.apache.org/jira/browse/KARAF-4692?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Paolo Antinori updated KARAF-4692:
----------------------------------
    Description: 
In case of a bundle with {{Bundle-ManifestVersion}} set to 1 (or without the clause completely),
{{bundle:install}} command **succeeds**, while {{feature:install}}, while installing a feature
containing a bundle with manifest version set to 1, **fails**.

{code}
karaf@root()> feature:install ibm 
Error executing command: Unable to build resource for mvn:com.ibm.mqjms/com.ibm.mqjms/7.5.0.6:
Unsupported 'Bundle-ManifestVersion' value: 1


2016-09-02 10:43:57,069 | ERROR | nsole user karaf | ShellUtil                        | 43
- org.apache.karaf.shell.core - 4.0.6 | Exception caught while executing command
org.osgi.framework.BundleException: Unable to build resource for mvn:com.ibm.mqjms/com.ibm.mqjms/7.5.0.6:
Unsupported 'Bundle-ManifestVersion' value: 1
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:80)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:65)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.region.SubsystemResolver.prepare(SubsystemResolver.java:143)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:218)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1176)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1074)[8:org.apache.karaf.features.core:4.0.6]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_102]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_102]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_102]
	at java.lang.Thread.run(Thread.java:745)[:1.8.0_102]
Caused by: org.osgi.framework.BundleException: Unsupported 'Bundle-ManifestVersion' value:
1
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.doBuild(ResourceBuilder.java:88)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:78)[8:org.apache.karaf.features.core:4.0.6]
	... 9 more
{code}

  was:
In case of a bundle with {{Bundle-ManifestVersion}} set to 1 (or without the clause completely),
{{bundle:install}} command succeeds, while {{feature:install}}, while installing a feature
containing a bundle with manifest version set to 1, fails.

{code}
karaf@root()> feature:install ibm 
Error executing command: Unable to build resource for mvn:com.ibm.mqjms/com.ibm.mqjms/7.5.0.6:
Unsupported 'Bundle-ManifestVersion' value: 1


2016-09-02 10:43:57,069 | ERROR | nsole user karaf | ShellUtil                        | 43
- org.apache.karaf.shell.core - 4.0.6 | Exception caught while executing command
org.osgi.framework.BundleException: Unable to build resource for mvn:com.ibm.mqjms/com.ibm.mqjms/7.5.0.6:
Unsupported 'Bundle-ManifestVersion' value: 1
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:80)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:65)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.region.SubsystemResolver.prepare(SubsystemResolver.java:143)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:218)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1176)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1074)[8:org.apache.karaf.features.core:4.0.6]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_102]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_102]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_102]
	at java.lang.Thread.run(Thread.java:745)[:1.8.0_102]
Caused by: org.osgi.framework.BundleException: Unsupported 'Bundle-ManifestVersion' value:
1
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.doBuild(ResourceBuilder.java:88)[8:org.apache.karaf.features.core:4.0.6]
	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:78)[8:org.apache.karaf.features.core:4.0.6]
	... 9 more
{code}


> Inconsistent behavior towards Bundle-ManifestVersion
> ----------------------------------------------------
>
>                 Key: KARAF-4692
>                 URL: https://issues.apache.org/jira/browse/KARAF-4692
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>    Affects Versions: 4.0.6
>            Reporter: Paolo Antinori
>
> In case of a bundle with {{Bundle-ManifestVersion}} set to 1 (or without the clause completely),
{{bundle:install}} command **succeeds**, while {{feature:install}}, while installing a feature
containing a bundle with manifest version set to 1, **fails**.
> {code}
> karaf@root()> feature:install ibm 
> Error executing command: Unable to build resource for mvn:com.ibm.mqjms/com.ibm.mqjms/7.5.0.6:
Unsupported 'Bundle-ManifestVersion' value: 1
> 2016-09-02 10:43:57,069 | ERROR | nsole user karaf | ShellUtil                      
 | 43 - org.apache.karaf.shell.core - 4.0.6 | Exception caught while executing command
> org.osgi.framework.BundleException: Unable to build resource for mvn:com.ibm.mqjms/com.ibm.mqjms/7.5.0.6:
Unsupported 'Bundle-ManifestVersion' value: 1
> 	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:80)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:65)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.region.SubsystemResolver.prepare(SubsystemResolver.java:143)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:218)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1176)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:1074)[8:org.apache.karaf.features.core:4.0.6]
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_102]
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_102]
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_102]
> 	at java.lang.Thread.run(Thread.java:745)[:1.8.0_102]
> Caused by: org.osgi.framework.BundleException: Unsupported 'Bundle-ManifestVersion' value:
1
> 	at org.apache.karaf.features.internal.resolver.ResourceBuilder.doBuild(ResourceBuilder.java:88)[8:org.apache.karaf.features.core:4.0.6]
> 	at org.apache.karaf.features.internal.resolver.ResourceBuilder.build(ResourceBuilder.java:78)[8:org.apache.karaf.features.core:4.0.6]
> 	... 9 more
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message