karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4516) Extend Karaf feature import version range in Decanter Kibana bundle
Date Tue, 07 Jun 2016 12:33:21 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4516?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15318390#comment-15318390
] 

ASF subversion and git services commented on KARAF-4516:
--------------------------------------------------------

Commit 95298c8e57bd1470d724f2338a0254da06ceb1fc in karaf-decanter's branch refs/heads/master
from [~jbonofre]
[ https://git-wip-us.apache.org/repos/asf?p=karaf-decanter.git;h=95298c8 ]

[KARAF-4516] Extend feature service import version range in Kibana 4.x bundle


> Extend Karaf feature import version range in Decanter Kibana bundle
> -------------------------------------------------------------------
>
>                 Key: KARAF-4516
>                 URL: https://issues.apache.org/jira/browse/KARAF-4516
>             Project: Karaf
>          Issue Type: Bug
>          Components: decanter
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: decanter-1.1.1
>
>
> Decanter Kibana bundle implements a FeatureListener to automatically update the Kibana
index and dashboards when user installs a collector.
> Unfortunately, the Karaf feature import range is {{[4,)}}, blocking the installation
of Decanter Kibana on Karaf 3.x, whereas it works fine with the Karaf 3 feature service.
> I will extend the version range to {{[3,)}} to allow to install Decanter Kibana on Karaf
3 and Karaf 4.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message