karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-4323) Can't install features openejb-cxf openejb-rest
Date Mon, 28 Mar 2016 05:54:25 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4323?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15213840#comment-15213840
] 

Jean-Baptiste Onofré commented on KARAF-4323:
---------------------------------------------

It's an issue in the openejb feature. It should be fixed and updated to support Karaf 4.

> Can't install features openejb-cxf openejb-rest
> -----------------------------------------------
>
>                 Key: KARAF-4323
>                 URL: https://issues.apache.org/jira/browse/KARAF-4323
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 3.0.5, 4.0.4
>            Reporter: Rocco Lagrotteria
>            Priority: Critical
>              Labels: features, karaf, openejb
>
> The installation of features openejb-cxf and openejb-rest fails because of missing requirement.
> {panel}
> *karaf@root()>* repo-add openejb 4.5.2
> Adding feature url mvn:org.apache.openejb/openejb-feature/4.5.2/xml/features
> *karaf@root()>* feature:install openejb-cxf
> {color:red}Error executing command: Unable to resolve root: missing requirement \[root\]
osgi.identity; osgi.identity=openejb-cxf; type=karaf.feature; version="\[4.5.2,4.5.2\]"; filter:="(&(osgi.identity=openejb-cxf)(type=karaf.feature)(version>=4.5.2)(version<=4.5.2))"
[caused by: Unable to resolve openejb-cxf/4.5.2: missing requirement \[openejb-cxf/4.5.2\]
osgi.identity; osgi.identity=org.apache.openejb.cxf-transport; type=osgi.bundle; version="\[4.5.2,4.5.2\]";
resolution:=mandatory [caused by: Unable to resolve org.apache.openejb.cxf-transport/4.5.2:
missing requirement \[org.apache.openejb.cxf-transport/4.5.2\] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.cxf.transport.http)(version>=2.6.0)(!(version>=3.0.0)))"\]\]{color}
> *karaf@root()>* feature:install openejb-rest
> {color:red}Error executing command: Unable to resolve root: missing requirement \[root\]
osgi.identity; osgi.identity=http-whiteboard; type=karaf.feature; version="\[2.0.0,4.0.0)"{color}
> {panel}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message