karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4358) Spring feature forces the wrong jta version. Can cause an error if it is installed before transaction
Date Wed, 24 Feb 2016 09:50:18 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4358?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15162745#comment-15162745
] 

ASF subversion and git services commented on KARAF-4358:
--------------------------------------------------------

Commit ef16e531ee1f54870ccfc43b4295fe77285b8c8c in karaf's branch refs/heads/karaf-4.0.x from
[~chris@die-schneider.net]
[ https://git-wip-us.apache.org/repos/asf?p=karaf.git;h=ef16e53 ]

[KARAF-4358] Use dependency true for spec bundles


> Spring feature forces the wrong jta version. Can cause an error if it is installed before
transaction
> -----------------------------------------------------------------------------------------------------
>
>                 Key: KARAF-4358
>                 URL: https://issues.apache.org/jira/browse/KARAF-4358
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 4.0.4
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>             Fix For: 4.1.0, 4.0.5
>
>
> To reproduce execute:
> feature:install spring-tx
> feature:install transaction
> Both jta 1.1 and 1.2 bundles will be installed. This causes aries transaction to hang
on startup as it does not find the transaction manager service.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message