karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roland Hauser (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-4317) NullPointerException when adding a feature repository to a cluster
Date Fri, 05 Feb 2016 11:39:39 GMT
Roland Hauser created KARAF-4317:
------------------------------------

             Summary: NullPointerException when adding a feature repository to a cluster
                 Key: KARAF-4317
                 URL: https://issues.apache.org/jira/browse/KARAF-4317
             Project: Karaf
          Issue Type: Bug
          Components: cellar-features
            Reporter: Roland Hauser
            Priority: Critical


I have a cluster with 2 nodes. Both nodes have the feature listener enabled (org.apache.karaf.cellar.node.cfg
/ feature.listener = true).
On node 1, I install a custom feature repository with following command:

{{feature:repo-add  mvn:com.bechtle.terra/com.bechtle.terra.renderer.feature/LATEST/xml/features}}

On node 2, I get a NullPointerException:

{code}
2016-02-05 11:10:39,849 | ERROR | pool-50-thread-1 | RepositoryEventHandler           | 64
- org.apache.karaf.cellar.features - 4.0.0 | CELLAR FEATURE: failed to add/remove repository
URL mvn:com.bechtle.terra/com.bechtle.terra.renderer.feature/LATEST/xml/features
java.lang.NullPointerException
	at org.apache.karaf.cellar.features.RepositoryEventHandler.handle(RepositoryEventHandler.java:80)[64:org.apache.karaf.cellar.features:4.0.0]
	at org.apache.karaf.cellar.features.RepositoryEventHandler.handle(RepositoryEventHandler.java:29)[64:org.apache.karaf.cellar.features:4.0.0]
	at org.apache.karaf.cellar.core.event.EventDispatchTask.run(EventDispatchTask.java:57)[63:org.apache.karaf.cellar.core:4.0.0]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)[:1.7.0_55]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)[:1.7.0_55]
	at java.lang.Thread.run(Unknown Source)[:1.7.0_55]
{code}	

The same effect occurs when I use the dedicated cluster command:
{{cluster:feature-repo-add default mvn:com.bechtle.terra/com.bechtle.terra.renderer.feature/LATEST/xml/features}}

When I disable the feature listener (org.apache.karaf.cellar.node.cfg / feature.listener =
true), the cluster-command
{{cluster:feature-repo-add default mvn:com.bechtle.terra/com.bechtle.terra.renderer.feature/LATEST/xml/features}}
works as exepected. The repository is then also available on node 2 and the feature can be
installed.

If I did something wrong, it would nevertheless be helpful if an error message would tell
what caused the problem.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message