karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Croquette (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4309) Missing dependency javax.transaction.TransactionManager with transaction feature and activemq-camel
Date Tue, 23 Feb 2016 12:40:18 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4309?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15158801#comment-15158801
] 

David Croquette commented on KARAF-4309:
----------------------------------------

I can also see the problem with the java.transaction but when repeating this issue in Karaf
4.0.4 it is transaction/1.3.0 that is installed. 

{{karaf@root()> feature:list | grep transaction
transaction-api               | 1.1.0            |          | Uninstalled | enterprise-4.0.4
        |
transaction-api               | 1.2.0            |          | Uninstalled | enterprise-4.0.4
        |
transaction                   | 1.3.0            |          | Uninstalled | enterprise-4.0.4
        | OSGi Transaction Manager

feature:repo-add activemq
feature:repo-add camel 
feature:install transaction activemq-camel

karaf@root()> feature:list | grep transaction
transaction-api                         | 1.1.0            |          | Started     | enterprise-4.0.4
           |
transaction-api                         | 1.2.0            |          | Started     | enterprise-4.0.4
           |
transaction                             | 1.3.0            | x        | Started     | enterprise-4.0.4
           | OSGi Transaction Manager}}

So that is unfortunately not the way around this issue.





> Missing dependency javax.transaction.TransactionManager with transaction feature and
activemq-camel
> ---------------------------------------------------------------------------------------------------
>
>                 Key: KARAF-4309
>                 URL: https://issues.apache.org/jira/browse/KARAF-4309
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.0.4, 4.0.5
>            Reporter: David Croquette
>
> Installing features transaction and activemq-camel one at a time manually from console
causes no problem. Installing them as dependent features either in a feature.xml or from console
> feature:repo-add activemq
> feature:repo-add camel 
> feature:install transaction activemq-camel 
> sets bundles in grace period:
> karaf@root()> diag
> Apache Aries Transaction Blueprint (58)
> ---------------------------------------
> Status: GracePeriod
> Blueprint
> 03/02/16 11:14
> Missing dependencies:
> (objectClass=javax.transaction.TransactionManager)
> Apache Aries Transaction Blueprint (59)
> ---------------------------------------
> Status: GracePeriod
> Blueprint
> 03/02/16 11:14
> Missing dependencies:
> (objectClass=javax.transaction.TransactionManager)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message