karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-4197) Upgrade to blueprint.core-1.5.0, jpa-2.3.0, transaction.blueprint-2.1.0
Date Thu, 07 Jan 2016 09:34:39 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4197?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15087115#comment-15087115
] 

Jean-Baptiste Onofré commented on KARAF-4197:
---------------------------------------------

I'm preparing the JPA 2.3.0 feature update:

NB: aries.jpa.container 2.3.0 requires org.osgi.service.jdbc package:

{code}
[root] osgi.identity; osgi.identity=jpa; type=karaf.feature; version=2.3.0; filter:="(&(osgi.identity=jpa)(type=karaf.feature)(version>=2.3.0))"
[caused by: Unable to resolve jpa/2.3.0: missing requirement [jpa/2.3.0] osgi.identity; osgi.identity=org.apache.aries.jpa.container;
type=osgi.bundle; version="[2.3.0,2.3.0]"; resolution:=mandatory [caused by: Unable to resolve
org.apache.aries.jpa.container/2.3.0: missing requirement [org.apache.aries.jpa.container/2.3.0]
osgi.wiring.package; filter:="(&(osgi.wiring.package=org.osgi.service.jdbc)(version>=1.0.0)(!(version>=2.0.0)))"]]
{code}

> Upgrade to blueprint.core-1.5.0, jpa-2.3.0, transaction.blueprint-2.1.0
> -----------------------------------------------------------------------
>
>                 Key: KARAF-4197
>                 URL: https://issues.apache.org/jira/browse/KARAF-4197
>             Project: Karaf
>          Issue Type: Dependency upgrade
>    Affects Versions: 4.0.3
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>             Fix For: 4.0.4
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message