karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Resolved] (KARAF-4031) Unresolved repository inside the feature causes Karaf freezing during startup
Date Tue, 05 Jan 2016 17:01:39 GMT

     [ https://issues.apache.org/jira/browse/KARAF-4031?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré resolved KARAF-4031.
-----------------------------------------
    Resolution: Fixed

> Unresolved repository inside the feature causes Karaf freezing during startup
> -----------------------------------------------------------------------------
>
>                 Key: KARAF-4031
>                 URL: https://issues.apache.org/jira/browse/KARAF-4031
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.0.1
>         Environment: Windows
>            Reporter: Andrei Shakirin
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.4
>
>
> I have observed following behavior: there is a feature containing a repository URL inside
the feature.xml:
> {code:xml}
> <?xml version="1.0" encoding="UTF-8"?>
> <features 
>         name="${project.artifactId}-${project.version}"
>         xmlns="http://karaf.apache.org/xmlns/features/v1.0.0"
>         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
>         xsi:schemaLocation="http://karaf.apache.org/xmlns/features/v1.0.0 http://karaf.apache.org/xmlns/features/v1.0.0
">
>     <repository>mvn:org.mycompany/thirdparty-features/9.9.9/xml</repository>
>     <feature name="test-bad" version="${project.version}">
>         <feature>thirdparty-commons</feature>
>     </feature>
> </features>
> {code}
> The repository URL mvn:org.mycompany/thirdparty-features/9.9.9/xml is not exist and cannot
be resolved.
> I specify the feature URL in org.apache.karaf.features.cfg featuresRepositories, but
NOT mention the feature in featuresBoot:
> {code:xml}
> featuresRepositories = \
>     mvn:org.apache.karaf.features/enterprise/4.0.1/xml/features, \
>     mvn:org.apache.karaf.features/framework/4.0.1/xml/features, \
>     mvn:org.apache.karaf.features/spring/4.0.1/xml/features, \
>     mvn:org.apache.karaf.features/standard/4.0.1/xml/features,\
>     mvn:org.mycompany/test-bad/1.0.0-SNAPSHOT/xml
> #
> # Comma separated list of features to install at startup
> #
> featuresBoot = \
>     aries-blueprint, \
>     bundle, \
>     config, \
>     deployer, \
>     diagnostic, \
>     feature, \
>     instance, \
>     jaas, \
>     kar, \
>     log, \
>     management, \
>     package, \
>     service, \
>     shell, \
>     shell-compat, \
>     ssh, \
>     system, \
>     wrap
> {code}
> Current behavior:
> 1) Karaf writes error message in the log file:
> java.io.IOException: Error resolving artifact org.mycompany:thirdparty-features:xml:9.9.9:
Could not find artifact org.mycompany:thirdparty-features:xml:9.9.9 in central (http://repo1.maven.org/maven2/)
: mvn:org.mycompany/thirdparty-features/9.9.9/xml
> (absolutely correct)
> 2) further startup process is completely blocked (problem)
> Expected behavior: write error message and continue startup process: feature is not specified
in featuresBoot and must not be installed.
> Interesting, if unresolved feature URL is specified directly in featuresRepositories,
Karaf proceed it correctly: writes error message, but continues startup. Blocking appears
only if unresolved URL is specified inside the feature.xml.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message