karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrea Cosentino (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KARAF-4191) Remove fabric8 karaf-features as it doesn't exists anymore
Date Sun, 13 Dec 2015 16:01:46 GMT

     [ https://issues.apache.org/jira/browse/KARAF-4191?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrea Cosentino updated KARAF-4191:
------------------------------------
    Description: 
Actually for Cellar-kubernetes feature we refer to Fabric8 Karaf-features module that doesn't
exists anymore from fabric8 2.2.43 (now we are on 2.2.76).
You can see the commit here: https://github.com/fabric8io/fabric8/pull/4908

Since we are currently using kubernetes-client 1.3.22 that is very old, we can upgrade the
client, remove the reference to Fabric8 karaf-features module and use a feature like this:
https://github.com/fabric8io/kubernetes-client/blob/master/platforms/karaf/features/src/main/resources/feature.xml#L18

What do you think about? I can take care of this.

  was:
Actually for Cellar-kubernetes feature we refer to Fabric8 Karaf-features module that doesn't
exists anymore from fabric8 2.2.43 (now we are on 2.2.76).

Since we are currently using kubernetes-client 1.3.22 that is very old, we can upgrade the
client, remove the reference to Fabric8 karaf-features module and use a feature like this:
https://github.com/fabric8io/kubernetes-client/blob/master/platforms/karaf/features/src/main/resources/feature.xml#L18

What do you think about? I can take care of this.


> Remove fabric8 karaf-features as it doesn't exists anymore
> ----------------------------------------------------------
>
>                 Key: KARAF-4191
>                 URL: https://issues.apache.org/jira/browse/KARAF-4191
>             Project: Karaf
>          Issue Type: Task
>          Components: cellar-core
>            Reporter: Andrea Cosentino
>            Priority: Minor
>
> Actually for Cellar-kubernetes feature we refer to Fabric8 Karaf-features module that
doesn't exists anymore from fabric8 2.2.43 (now we are on 2.2.76).
> You can see the commit here: https://github.com/fabric8io/fabric8/pull/4908
> Since we are currently using kubernetes-client 1.3.22 that is very old, we can upgrade
the client, remove the reference to Fabric8 karaf-features module and use a feature like this:
https://github.com/fabric8io/kubernetes-client/blob/master/platforms/karaf/features/src/main/resources/feature.xml#L18
> What do you think about? I can take care of this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message