karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Leangen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-4161) Adding requirement does not resolve required bundles
Date Thu, 03 Dec 2015 11:23:11 GMT

    [ https://issues.apache.org/jira/browse/KARAF-4161?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15037685#comment-15037685
] 

David Leangen commented on KARAF-4161:
--------------------------------------

Unfortunately the problem persists. :-(

Example: when I add com.me.whatever.prevayler, which requires osgi.wiring.package=com.thoughtworks.xstream,
my expectation is that xstream should also get installed. But it does not. I have to install
it manually.

xstream is in a different OBR than prevayler.

In org.apache.karaf.features.cfg, it looks something like this:

{code}
resourceRepositories=, \
    xml:http://my.repo.com/repo/dependencies/index.xml,\ [1]
    xml:file:/Users/dleangen/release/index.xml [2]
{code}

[1] is the OBR with third party dependencies including xstream, and [2] is the OBR with "my
stuff" including prevayler.

> Adding requirement does not resolve required bundles
> ----------------------------------------------------
>
>                 Key: KARAF-4161
>                 URL: https://issues.apache.org/jira/browse/KARAF-4161
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>            Reporter: David Leangen
>            Assignee: Guillaume Nodet
>
> When using
> {code}
> feature:requirement-add ‘requirement:osgi.identity;osgi.identity=my.bundle;type=osgi.bundle'
> {code}
> required bundles are not getting resolved, even if they exist in an installed repository.
This seems to occur when the required bundle is available from a different repository.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message