karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KARAF-3972) can't genrate feature with prerequisite using karaf-maven-plugin
Date Thu, 22 Oct 2015 03:44:27 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3972?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Freeman Fang resolved KARAF-3972.
---------------------------------
       Resolution: Fixed
    Fix Version/s: 4.0.3

commit fix
http://git-wip-us.apache.org/repos/asf/karaf/commit/d7a1e9a2 for master

> can't genrate feature with prerequisite using karaf-maven-plugin
> ----------------------------------------------------------------
>
>                 Key: KARAF-3972
>                 URL: https://issues.apache.org/jira/browse/KARAF-3972
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.0.1
>            Reporter: Amichai Rothman
>            Assignee: Freeman Fang
>             Fix For: 4.0.3
>
>
> When upgrading from Karaf 3.0.3 to 4.0.1, integration tests fail do to missing wrap feature
(exception because of "unknown protocol: wrap"). The solution is presumably to add wrap as
a prerequisite for my own feature by adding the appropriate attribute in the feature xml.
> However, the feature xml is being generated using karaf-maven-plugin, and there seems
to be no way to add the prerequisite attribute to the generated feature xml file.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message