karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Kleemann (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-3748) Installing activemq-blueprint feature sometimes fails with uses constraint violation
Date Thu, 03 Sep 2015 16:16:46 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3748?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14729336#comment-14729336
] 

Jens Kleemann commented on KARAF-3748:
--------------------------------------

I experience a similar problem upon custom distribution assembly: 

(when i reference the enterprise feature as compile dependency the build never ends emitting
thousands of these failed permutations, when i omit enterprise i get the same errors but the
build ends):



[DEBUG] Candidate permutation failed due to a conflict between imports; will try another if
possible.
org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve
resource org.apache.karaf.features.core [org.apache.karaf.features.core/4.0.1] because it
is exposed to package 'org.osgi.resource' from resources osgi.core [osgi.core/5.0.0.201203141902]
and system.bundle [system.bundle/0.0.0] via two dependency chains.

Chain 1:
  org.apache.karaf.features.core [org.apache.karaf.features.core/4.0.1]
    import: (&(osgi.wiring.package=org.osgi.resource)(version>=1.0.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package: org.osgi.resource
  osgi.core [osgi.core/5.0.0.201203141902]

Chain 2:
  org.apache.karaf.features.core [org.apache.karaf.features.core/4.0.1]
    import: (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.1.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package=org.eclipse.equinox.region; uses:=org.osgi.framework.hooks.resolver
  org.apache.karaf.features.core [org.apache.karaf.features.core/4.0.1]
    import: (&(osgi.wiring.package=org.osgi.framework.hooks.resolver)(version>=1.0.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package: org.osgi.framework.hooks.resolver; uses:=org.osgi.resource
    export: osgi.wiring.package=org.osgi.resource
  system.bundle [system.bundle/0.0.0]
	at org.apache.felix.resolver.ResolverImpl.checkDynamicPackageSpaceConsistency(ResolverImpl.java:1410)
	at org.apache.felix.resolver.ResolverImpl.checkPackageSpaceConsistency(ResolverImpl.java:1190)
	at org.apache.felix.resolver.ResolverImpl.checkDynamicPackageSpaceConsistency(ResolverImpl.java:1502)

> Installing activemq-blueprint feature sometimes fails with uses constraint violation
> ------------------------------------------------------------------------------------
>
>                 Key: KARAF-3748
>                 URL: https://issues.apache.org/jira/browse/KARAF-3748
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>    Affects Versions: 4.0.0.M3
>            Reporter: Achim Finke
>
> From time to time you get the following exception when installing activemq-blueprint
feature. 
> {code}
> org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve
resource org.apache.activemq.activemq-blueprint [org.apache.activemq.activemq-blueprint/5.11.1]
because it is exposed to package 'org.apache.aries.blueprint' from resources org.apache.aries.blueprint.core
[org.apache.aries.blueprint.core/1.4.3] and org.apache.aries.blueprint.core [org.apache.aries.blueprint.core/1.4.3]
via two dependency chains.
> Chain 1:
>   org.apache.activemq.activemq-blueprint [org.apache.activemq.activemq-blueprint/5.11.1]
>     import: (&(osgi.wiring.package=org.apache.aries.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
>      |
>     export: osgi.wiring.package: org.apache.aries.blueprint
>   org.apache.aries.blueprint.core [org.apache.aries.blueprint.core/1.4.3]
> Chain 2:
>   org.apache.activemq.activemq-blueprint [org.apache.activemq.activemq-blueprint/5.11.1]
>     import: (&(osgi.wiring.package=org.apache.xbean.blueprint.context.impl)(version>=3.13.0)(!(version>=4.0.0)))
>      |
>     export: osgi.wiring.package=org.apache.xbean.blueprint.context.impl; uses:=org.apache.aries.blueprint
>   org.apache.xbean.blueprint [org.apache.xbean.blueprint/3.18.0]
>     import: (&(osgi.wiring.package=org.apache.aries.blueprint)(version>=1.0.0)(!(version>=2.0.0)))
>      |
>     export: osgi.wiring.package: org.apache.aries.blueprint
>   org.apache.aries.blueprint.core [org.apache.aries.blueprint.core/1.4.3]
> 	at org.apache.felix.resolver.ResolverImpl.checkDynamicPackageSpaceConsistency(ResolverImpl.java:1410)[org.apache.felix.framework-5.0.0.jar:]
> 	at org.apache.felix.resolver.ResolverImpl.checkPackageSpaceConsistency(ResolverImpl.java:1190)[org.apache.felix.framework-5.0.0.jar:]
> 	at org.apache.felix.resolver.ResolverImpl.checkDynamicPackageSpaceConsistency(ResolverImpl.java:1502)[org.apache.felix.framework-5.0.0.jar:]
> 	at org.apache.felix.resolver.ResolverImpl.checkPackageSpaceConsistency(ResolverImpl.java:1190)[org.apache.felix.framework-5.0.0.jar:]
> 	at org.apache.felix.resolver.ResolverImpl.checkDynamicPackageSpaceConsistency(ResolverImpl.java:1502)[org.apache.felix.framework-5.0.0.jar:]
> 	at org.apache.felix.resolver.ResolverImpl.checkPackageSpaceConsistency(ResolverImpl.java:1190)[org.apache.felix.framework-5.0.0.jar:]
> 	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:289)[org.apache.felix.framework-5.0.0.jar:]
> 	at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:185)[6:org.apache.karaf.features.core:4.0.0.SNAPSHOT]
> 	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:261)[6:org.apache.karaf.features.core:4.0.0.SNAPSHOT]
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1061)[6:org.apache.karaf.features.core:4.0.0.SNAPSHOT]
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:960)[6:org.apache.karaf.features.core:4.0.0.SNAPSHOT]
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_31]
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_31]
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_31]
> 	at java.lang.Thread.run(Thread.java:745)[:1.8.0_31]
> {code}
> The behaviour is not predictable. Installation worked x times, afterwards installation
failed y times so you may need some trys to reproduce.
> To reproduce execute:
> {code}
> feature:repo-add activemq 5.11.1
> feature:install activemq-blueprint
> {code}
> if you don't get the exception stop the container, delete data folder and try again.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message