karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-3822) Error installing feature even if requirements should be present
Date Wed, 01 Jul 2015 19:34:04 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14610882#comment-14610882
] 

Jean-Baptiste Onofré commented on KARAF-3822:
---------------------------------------------

Actually, the problem is in the org.eclipse.ecf.remoteservice.asyncproxy bundle: the Require-Capability
header in the MANIFEST doesn't contain a valid LDIF filter.

It should be:

{code}
 (&(|(osgi.ee = J2SE)(osgi.ee = JavaSE))(version >= 1.5)(!(version >= 1.8)))
{code}

> Error installing feature even if requirements should be present
> ---------------------------------------------------------------
>
>                 Key: KARAF-3822
>                 URL: https://issues.apache.org/jira/browse/KARAF-3822
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 4.0.0
>            Reporter: Christian Schneider
>         Attachments: req-issue.xml
>
>
> Unpack and start plain apache-karaf-4.0.0
> Download feature file to karaf dir.
> feature:repo-add file:req-issue.xml
> feature:install req-issue
> It will show the exception below. The strange thing is that the requirements should be
present.
> -----
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=bug1; type=karaf.feature; version="[1.0.0,1.0.0]"; filter:="(&(osgi.identity=bug1)(type=karaf.feature)(version>=1.0.0)(version<=1.0.0))"
[caused by: Unable to resolve bug1/1.0.0: missing requirement [bug1/1.0.0] osgi.identity;
osgi.identity=org.eclipse.ecf.remoteservice.asyncproxy; type=osgi.bundle; version="[1.0.0.v20140410-1838,1.0.0.v20140410-1838]";
resolution:=mandatory [caused by: Unable to resolve org.eclipse.ecf.remoteservice.asyncproxy/1.0.0.v20140410-1838:
missing requirement [org.eclipse.ecf.remoteservice.asyncproxy/1.0.0.v20140410-1838] osgi.ee;
filter="(&(|(osgi.ee = J2SE)(osgi.ee = JavaSE))(version >= 1.5)(!(version >= 1.8)))"]]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message