karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KARAF-3796) Provide aries jpa 2.0.0 and use feature for persistence-api
Date Fri, 19 Jun 2015 12:36:00 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3796?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christian Schneider updated KARAF-3796:
---------------------------------------
    Description: 
Provides aries jpa 2.0.0 and introduces a feature for the peristence-api to make it easier
to handle the different versions.

Examples:
feature:install jpa -> aries jpa 2.0.0, javax.persistence 2.1.0
feature:install jpa openjpa -> aries jpa 2.0.0, openjpa, javax.persistence 2.0.0
feature:install jpa openjpa -> aries jpa 2.0.0, hibernate/4.3.x, javax.persistence 2.1.0

So it by default uses api 2.1.0 but if the persistence provider need 2.0.0 it will use 2.0.0.

feature:install jpa/1.5.0 -> Installs the old aries jpa 1.x


> Provide aries jpa 2.0.0 and use feature for persistence-api
> -----------------------------------------------------------
>
>                 Key: KARAF-3796
>                 URL: https://issues.apache.org/jira/browse/KARAF-3796
>             Project: Karaf
>          Issue Type: Improvement
>    Affects Versions: 4.0.0.M3
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>             Fix For: 4.0.0
>
>
> Provides aries jpa 2.0.0 and introduces a feature for the peristence-api to make it easier
to handle the different versions.
> Examples:
> feature:install jpa -> aries jpa 2.0.0, javax.persistence 2.1.0
> feature:install jpa openjpa -> aries jpa 2.0.0, openjpa, javax.persistence 2.0.0
> feature:install jpa openjpa -> aries jpa 2.0.0, hibernate/4.3.x, javax.persistence
2.1.0
> So it by default uses api 2.1.0 but if the persistence provider need 2.0.0 it will use
2.0.0.
> feature:install jpa/1.5.0 -> Installs the old aries jpa 1.x



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message