karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Updated] (KARAF-3360) karaf-maven-plugin expects '$' as bundle URL argument separator
Date Mon, 25 May 2015 19:59:17 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3360?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated KARAF-3360:
----------------------------------------
    Fix Version/s:     (was: 4.0.0.M3)
                   4.0.0

> karaf-maven-plugin expects '$' as bundle URL argument separator
> ---------------------------------------------------------------
>
>                 Key: KARAF-3360
>                 URL: https://issues.apache.org/jira/browse/KARAF-3360
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-tooling
>    Affects Versions: 3.0.2, 4.0.0.M1
>            Reporter: Maciej Mraczek
>              Labels: feature
>             Fix For: 3.0.4, 4.0.0
>
>
> karaf-maven-plugin -> InstallKarsMojo -> installBundle exptects '$' as URL arguments
separator.
> The '$' is not properly recognized by Karaf core, so it is not possible to install feature
which contains bundle (i.e. webbundle) with URL with '$' used as argument separator.
> The symbol should be "?"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message