karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-3625) Password encryption doesn't work
Date Tue, 07 Apr 2015 13:44:12 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3625?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14483161#comment-14483161
] 

Jean-Baptiste Onofré commented on KARAF-3625:
---------------------------------------------

Regarding the other issue, the problem is a race condition: the AutoEncryptionSupport creates
an EncryptionSupport with the provided option. This EncryptionSupport is looking for an encryption
service. The blueprint container creates the basic encryption service, but, sometime, this
service is not yet registered when the EncryptionSupport does the lookup.
I fixed this by implementing a service lookup loop (with a timeout). I'm investigating to
see if there is no better way to do it.

> Password encryption doesn't work
> --------------------------------
>
>                 Key: KARAF-3625
>                 URL: https://issues.apache.org/jira/browse/KARAF-3625
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-security
>    Affects Versions: 3.0.3, 2.3.8, 2.3.9, 2.3.10, 4.0.0.M2
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>            Priority: Critical
>             Fix For: 2.4.2, 3.0.4, 2.3.11
>
>
> With encryption.enabled=true in etc/org.apache.karaf.jaas.cfg configuration file, Karaf
should encrypt the password in etc/users.properties (prefixing and suffixing with {CRYPT}
keyword).
> However, the password are not encrypted in the etc/users.properties.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message