karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (KARAF-3540) Bundle package conflicts with uninstalled bundles
Date Thu, 19 Feb 2015 11:50:12 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3540?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14327304#comment-14327304
] 

Sergey  edited comment on KARAF-3540 at 2/19/15 11:50 AM:
----------------------------------------------------------

I just expect another error message, probably. 

Because if I see something like "Where is conflict between bundle 123 and 456", and I can't
find bundle 456, this is a bit misleading. 

So, this is not bug to fix, but just an improvement, may be.

Thanks.


was (Author: cp123):
I just expect another error message, probably. 

Because if I see something like "Where is conflict between bundle 123 and 456", and I can't
find bundle 456, this is a bit misleading. Not to fix, just an improvement, may be.

> Bundle package conflicts with uninstalled bundles
> -------------------------------------------------
>
>                 Key: KARAF-3540
>                 URL: https://issues.apache.org/jira/browse/KARAF-3540
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-osgi
>            Reporter: Sergey 
>
> Karaf 3.0.3 reports about package conflicts for spring framework packages. One of conflicting
bundles is spring version 3.x, another one - 4.x. 
> Conflict exists even if I've ininstalled all spring 4.x bundles. 
> Conflicted spring 4.x bundles at the moment exists only in data/cache, not in bundle:list
command output.
> I can resolve this issue only after karaf restart. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message