karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Updated] (KARAF-3425) Need a solution to add a "specific version" of a feature in karaf-maven-plugin
Date Thu, 22 Jan 2015 09:39:35 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3425?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated KARAF-3425:
----------------------------------------
    Fix Version/s: 4.0.0.M2

> Need a solution to add a "specific version" of a feature in karaf-maven-plugin 
> -------------------------------------------------------------------------------
>
>                 Key: KARAF-3425
>                 URL: https://issues.apache.org/jira/browse/KARAF-3425
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-tooling
>    Affects Versions: 3.0.2
>            Reporter: Mohammad Shamsi
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.0, 3.0.3, 4.0.0.M2
>
>
> Given a feature repository with different versions of same feature.
> karaf-maven-plugin always installs the latest version of the feature
> and there is *no way* to install older versions of the feature.
>  
> For example: spring 3.1.x, 3.2.x and 4.0.x are available in "org.apache.karaf.feature"
> Adding "spring" in to feature list of karaf-maven-plugin installs 4.0.x. and there is
no way to provide the feature version



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message