karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Updated] (KARAF-3379) jpa feature incompatible to hibernate 4.3 feature
Date Thu, 22 Jan 2015 09:53:35 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3379?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated KARAF-3379:
----------------------------------------
    Fix Version/s: 4.0.0.M2

> jpa feature incompatible to hibernate 4.3 feature
> -------------------------------------------------
>
>                 Key: KARAF-3379
>                 URL: https://issues.apache.org/jira/browse/KARAF-3379
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 3.0.2
>            Reporter: Christian Schneider
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.0, 3.0.3, 2.4.1, 4.0.0.M2
>
>
> The jpa feature loads the jpa 2.0 spec bundle:
> <bundle dependency="true" start-level="30">mvn:org.apache.geronimo.specs/geronimo-jpa_2.0_spec/${geronimo.jpa-spec.version}</bundle>
> The hibernate 4.3.6 feature loads the jpa 2.1 spec bundle:
> <bundle dependency="true" start-level="30">mvn:org.hibernate.javax.persistence/hibernate-jpa-2.1-api/1.0.0.Final</bundle>
> This will not work as aries jpa.container only works if exactly one jpa spec bundle is
installed.
> For hibernate 4.3 only the jpa 2.1 bundle should be present.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message