karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Updated] (KARAF-3370) itests using ssh or cdi related fail
Date Thu, 22 Jan 2015 09:55:34 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3370?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated KARAF-3370:
----------------------------------------
    Fix Version/s: 4.0.0.M2

> itests using ssh or cdi related fail
> ------------------------------------
>
>                 Key: KARAF-3370
>                 URL: https://issues.apache.org/jira/browse/KARAF-3370
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-test
>    Affects Versions: 4.0.0
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.0, 4.0.0.M2
>
>
> Currently, the Karaf itest fail for mostly two reasons:
> * security related, the ssh connections fail, for instance:
> {code}
> testShellCommandSecurityViaSsh(org.apache.karaf.itests.ShellCommandSecurityTest) , cause:
Could not open SSH channel
> {code}
> * CDI features installation
> {code}
> installPaxCdi12WeldFeature(org.apache.karaf.itests.features.CdiFeaturesTest) , cause:
Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=pax-cdi-1.2-weld;
type=karaf.feature; version="[0.9.0,0.9.0]"; filter:="(&(osgi.identity=pax-cdi-1.2-weld)(type=karaf.feature)(version>=0.9.0)(version<=0.9.0))"
[caused by: Unable to resolve pax-cdi-1.2-weld/0.9.0: missing requirement [pax-cdi-1.2-weld/0.9.0]
osgi.identity; osgi.identity=org.ops4j.pax.cdi.weld; type=osgi.bundle; version="[0.9.0,0.9.0]";
resolution:=mandatory [caused by: Unable to resolve org.ops4j.pax.cdi.weld/0.9.0: missing
requirement [org.ops4j.pax.cdi.weld/0.9.0] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.jboss.weld.bootstrap)(version>=1.0.0)(!(version>=3.0.0)))"
[caused by: Unable to resolve org.jboss.weld.osgi-bundle/2.2.4.Final: missing requirement
[org.jboss.weld.osgi-bundle/2.2.4.Final] osgi.wiring.package; filter:="(&(osgi.wiring.package=javax.annotation)(version>=1.1.0)(!(version>=2147483647.2147483647.2147483647)))"]]]
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message