karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-3244) EntityManager Factory not available
Date Sat, 20 Sep 2014 16:31:34 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3244?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14142093#comment-14142093
] 

Jean-Baptiste Onofré commented on KARAF-3244:
---------------------------------------------

It's probably due to the Aries JPA update.

Now, you have multiple jpa feature version. It should work with:

{code}
karaf@root()> feature:install jpa/1.0.1
{code}

The issue is, without the version specify, it uses jpa 1.0.2 (with JPA 2.1).

> EntityManager Factory not available 
> ------------------------------------
>
>                 Key: KARAF-3244
>                 URL: https://issues.apache.org/jira/browse/KARAF-3244
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 3.0.2
>         Environment: Mac OSX, Java7, Karaf 3.0.2-SNAPSHOT (latest from repo)
>            Reporter: Achim Nierbeck
>            Priority: Blocker
>             Fix For: 3.0.2
>
>
> When installing a test application for JPA it fails to start due to a graceperiod and
waiting for the EntityManager. 
> Eventually if fails to start the bundle: 
> {code}
> due to unresolved dependencies [(&(&(org.apache.aries.jpa.proxy.factory=true)(osgi.unit.name=inventory))(objectClass=javax.persistence.EntityManagerFactory))]
> {code}
> right now the standard features for JPA are not usable this way. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message