karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-3230) jndi feature doesn't install
Date Tue, 16 Sep 2014 06:03:35 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3230?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14135018#comment-14135018
] 

Jean-Baptiste Onofré commented on KARAF-3230:
---------------------------------------------

The problem is caused by Aries JNDI URL 1.1.0-SNAPSHOT, which requires an update on JNDI Core.

For now, I'm downgrading to Aries JNDI URL to 1.0.0, I will update both JNDI Core and JNDI
URL in a row.

> jndi feature doesn't install
> ----------------------------
>
>                 Key: KARAF-3230
>                 URL: https://issues.apache.org/jira/browse/KARAF-3230
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 4.0.0
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.0
>
>
> {code}
> org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement
[root] osgi.identity; osgi.identity=jndi; type=karaf.feature; version="[4.0.0.SNAPSHOT,4.0.0.SNAPSHOT]";
filter:="(&(osgi.identity=jndi)(type=karaf.feature)(version>=4.0.0.SNAPSHOT)(version<=4.0.0.SNAPSHOT))"
[caused by: Unable to resolve jndi/4.0.0.SNAPSHOT: missing requirement [jndi/4.0.0.SNAPSHOT]
osgi.identity; osgi.identity=org.apache.aries.jndi.url; type=osgi.bundle; version="[1.1.0.SNAPSHOT,1.1.0.SNAPSHOT]";
resolution:=mandatory [caused by: Unable to resolve org.apache.aries.jndi.url/1.1.0.SNAPSHOT:
missing requirement [org.apache.aries.jndi.url/1.1.0.SNAPSHOT] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.aries.jndi.spi)(version>=1.1.0)(!(version>=2.0.0)))"]]
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message