karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Created] (KARAF-3179) aries-annotation feature doesn't install
Date Sun, 24 Aug 2014 05:53:11 GMT
Jean-Baptiste Onofré created KARAF-3179:
-------------------------------------------

             Summary: aries-annotation feature doesn't install
                 Key: KARAF-3179
                 URL: https://issues.apache.org/jira/browse/KARAF-3179
             Project: Karaf
          Issue Type: Bug
          Components: karaf-core
    Affects Versions: 3.0.2
            Reporter: Jean-Baptiste Onofré
            Assignee: Jean-Baptiste Onofré
             Fix For: 3.0.2


The aries-annotation feature can't be installed due to XBean package version mismatch:

{code}
Could not start bundle mvn:org.apache.aries.blueprint/org.apache.aries.blueprint.annotation.impl/1.0.1
in feature(s) aries-annotation-3.0.2-SNAPSHOT: Unresolved constraint in bundle org.apache.aries.blueprint.annotation.impl
[82]: Unable to resolve 82.0: missing requirement [82.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.xbean.finder)(version>=3.18.0)(!(version>=4.0.0)))
{/code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message