karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-3158) Incorrect javax.annotation version for java7
Date Mon, 11 Aug 2014 11:45:11 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14092697#comment-14092697
] 

Jean-Baptiste Onofré commented on KARAF-3158:
---------------------------------------------

Fixed on karaf-2.3.x: https://git-wip-us.apache.org/repos/asf?p=karaf.git;a=commitdiff;h=ba29f28ca5e03caa21a9f3a2d29ebacb9f3c541b

> Incorrect javax.annotation version for java7
> --------------------------------------------
>
>                 Key: KARAF-3158
>                 URL: https://issues.apache.org/jira/browse/KARAF-3158
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 3.0.1
>            Reporter: Ivan Op de Beeck
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.4.0, 4.0.0, 3.0.2, 2.3.7
>
>
> See comments in KARAF-2660
> In jre.properties it is assumed that jre-1.7 supports javax.annotation;version="1.2",
but this seems to be incorrect.
> Deploying bundles that depend on javax.annotation-1.2 specific behaviour will therefore
fail.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message