karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harald Wellmann (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-3155) Cannot override broken feature version
Date Fri, 08 Aug 2014 21:23:12 GMT
Harald Wellmann created KARAF-3155:
--------------------------------------

             Summary: Cannot override broken feature version
                 Key: KARAF-3155
                 URL: https://issues.apache.org/jira/browse/KARAF-3155
             Project: Karaf
          Issue Type: Bug
            Reporter: Harald Wellmann


Scenario:

To test my local fix for the broken feature repository org.ops4j.pax.cdi-0.7.0, I installed
a corrected version org.ops4j.pax.cdi-0.8.0-SNAPSHOT and then tried to install the corrected
feature pax-cdi-deltaspike-core via

{noformat}
feature:install pax-cdi-deltaspike-core/1.0.0
feature:install pax-cdi-deltaspike-core;version=1.0.0
{noformat}

Expected behaviour:

Karaf installs the specified feature version and does not even look at any other version.

Actual behaviour:

Installation fails with error message

{noformat}
Error executing command: invalid version ">0.5": non-numeric ">0"
{noformat}

The only workaround I could find was:
* Delete the {{enterprise}} feature from the {{featureRepositories}} list in {{org.apache.karaf.features.cfg}}
* Delete my {{data/}} directory 
* Install the new corrected feature repository and feature.





--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message