karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Achim Nierbeck (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (KARAF-3137) Karaf doesn't start due to jline constraint
Date Mon, 28 Jul 2014 21:31:38 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3137?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Achim Nierbeck reassigned KARAF-3137:
-------------------------------------

    Assignee: Achim Nierbeck  (was: Jean-Baptiste Onofré)

> Karaf doesn't start due to jline constraint
> -------------------------------------------
>
>                 Key: KARAF-3137
>                 URL: https://issues.apache.org/jira/browse/KARAF-3137
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-shell
>    Affects Versions: 3.0.2
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Achim Nierbeck
>            Priority: Blocker
>             Fix For: 3.0.2
>
>
> A recent change in Karaf 3.0.2-SNAPSHOT makes Karaf startup failed:
> {code}
> ERROR: Bundle org.apache.karaf.features.command [35] Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.command/3.0.2-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command
[35]: Unable to resolve 35.0: missing requirement [35.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.shell.commands)(version>=3.0.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.shell.console.jline)])
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command
[35]: Unable to resolve 35.0: missing requirement [35.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.shell.commands)(version>=3.0.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.shell.console.jline)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2037)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1291)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
>         at java.lang.Thread.run(Thread.java:745)
> ERROR: Bundle org.apache.karaf.shell.console [36] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/3.0.2-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console
[36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.shell.console.jline))
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console
[36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.shell.console.jline)
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2037)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1291)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
>         at java.lang.Thread.run(Thread.java:745)
> ERROR: Bundle org.apache.karaf.bundle.command [40] Error starting mvn:org.apache.karaf.bundle/org.apache.karaf.bundle.command/3.0.2-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.bundle.command
[40]: Unable to resolve 40.0: missing requirement [40.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.shell.commands)(version>=3.0.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.shell.console.jline)])
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.bundle.command
[40]: Unable to resolve 40.0: missing requirement [40.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.karaf.shell.commands)(version>=3.0.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.shell.console.jline)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2037)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1291)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
>         at java.lang.Thread.run(Thread.java:745)
> ...
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message