karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Barthel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-933) War feature installation failed with Java 5
Date Thu, 31 Jul 2014 18:17:39 GMT

    [ https://issues.apache.org/jira/browse/KARAF-933?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14081218#comment-14081218
] 

Uwe Barthel commented on KARAF-933:
-----------------------------------

This issue blocks the Karaf 2.2.12 release.

Did the dependency was fixed by pax or it's possible to move this issue to a later 2.2.x release?

> War feature installation failed with Java 5
> -------------------------------------------
>
>                 Key: KARAF-933
>                 URL: https://issues.apache.org/jira/browse/KARAF-933
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-webcontainer
>    Affects Versions: 2.2.3, 2.2.4, 2.2.5
>            Reporter: Jean-Baptiste Onofré
>             Fix For: 2.2.12
>
>
> If the features:install war works without problem with Java 6, it fails using Java 5:
> Could not start bundle mvn:org.ops4j.pax.web/pax-web-jsp/1.0.7 in feature(s) war-2.2.4-SNAPSHOT:
Unresolved constraint in bundle org.ops4j.pax.web.pax-web-jsp [73]: Unable to resolve 73.0:
missing requirement [73.0] package; (package=javax.annotation.processing)
> To be Java 5 compliant, the war feature should use the Geronimo annotation spec bundle.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message