karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KARAF-3030) Karaf doesn't support Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))
Date Mon, 16 Jun 2014 08:51:01 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3030?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Freeman Fang resolved KARAF-3030.
---------------------------------

    Resolution: Cannot Reproduce

> Karaf doesn't support Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))
> -------------------------------------------------------------------------------------------
>
>                 Key: KARAF-3030
>                 URL: https://issues.apache.org/jira/browse/KARAF-3030
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 3.0.1
>            Reporter: ChengRen
>
> I have a bundle who's manifest contains osgi header: 
>   Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))
> when i run the bundle in karaf 3.0.1, I got bundle can not be resolved error :
> Error executing command: Error executing command on bundles:
>         Unable to execute command on bundle 182: The bundle "myproject.core.api_1.0.0.201405150206
[182]" could not be res
> olved. Reason: Missing Constraint: Require-Capability: osgi.ee; filter="(&(osgi.ee=JavaSE)(version=1.7))"
> When I check karaf config.properties, I found "org.osgi.framework.system.capabilities"
property which export osgi.ee.
> Is this a karaf bug??



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message