karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Assigned] (KARAF-3010) jclouds-commands cannot resolve correct version of Karaf shell
Date Tue, 10 Jun 2014 13:47:01 GMT

     [ https://issues.apache.org/jira/browse/KARAF-3010?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré reassigned KARAF-3010:
-------------------------------------------

    Assignee: Jean-Baptiste Onofré

> jclouds-commands cannot resolve correct version of Karaf shell
> --------------------------------------------------------------
>
>                 Key: KARAF-3010
>                 URL: https://issues.apache.org/jira/browse/KARAF-3010
>             Project: Karaf
>          Issue Type: Dependency upgrade
>          Components: karaf-shell
>    Affects Versions: 3.0.1
>            Reporter: Ryan Moquin
>            Assignee: Jean-Baptiste Onofré
>
> Installing the jclouds-commands feature will fail due to it looking for the karaf shell
console bundle minimum version 2.2.0, but Karaf 3.0.1 uses version 2.11.0.
> karaf@root()> feature:install jclouds-commands
> Error executing command: Could not start bundle mvn:org.apache.jclouds.karaf/commands/1.7.2
in feature(s) jclouds-commands-1.7.2: Unres
> olved constraint in bundle org.apache.jclouds.karaf.commands [135]: Unable to resolve
135.0: missing requirement [135.0] osgi.wiring.pa
> ckage; (&(osgi.wiring.package=org.apache.karaf.shell.console.jline)(version>=2.2.0))
> Manually installing it, will prevent that error:
> karaf@root()> bundle:install mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.2.0
> but when trying to install the feature again:
> karaf@root()> feature:install jclouds-commands
> Error executing command: Could not start bundle mvn:org.apache.jclouds.karaf/commands/1.7.2
in feature(s) jclouds-commands-1.7.2: Unres
> olved constraint in bundle org.apache.jclouds.karaf.commands [189]: Unable to resolve
189.0: missing requirement [189.0] osgi.wiring.pa
> ckage; (&(osgi.wiring.package=org.apache.karaf.shell.console.jline)(version>=2.2.0))
[caused by: Unable to resolve 141.0: missing requi
> rement [141.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.blueprint)(version>=0.3.0)(!(version>=1.0.0)))]
> Shows that the karaf shell console bundle version 2.2.0 is relying on some old bundle
versions.  If I list the headers of version 2.2.0 to see what all is wrong, these are the
lines in the manifest it flags as unresolved:
> org.apache.aries.blueprint;version="[0.3,1)",
> org.apache.aries.blueprint.mutable;version="[0.3,1)",
> org.apache.karaf.jaas.modules;version="[2.2,3)",
> org.fusesource.hawtjni.runtime;version="[1.0,2)",:



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message