karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-2883) Use better version range in Spring features
Date Sat, 05 Apr 2014 05:21:14 GMT

    [ https://issues.apache.org/jira/browse/KARAF-2883?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13960975#comment-13960975
] 

Jean-Baptiste Onofré commented on KARAF-2883:
---------------------------------------------

Fixed on master: https://git-wip-us.apache.org/repos/asf?p=karaf.git;a=commitdiff;h=3b3cfaad25d72433994dc9d79e8d224f0a98b33c

> Use better version range in Spring features
> -------------------------------------------
>
>                 Key: KARAF-2883
>                 URL: https://issues.apache.org/jira/browse/KARAF-2883
>             Project: Karaf
>          Issue Type: Improvement
>          Components: karaf-feature
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.4.0, 3.0.1, 4.0.0
>
>
> Now, a Spring feature "imports" the "spring" feature using the version:
> {code}
> <feature name="spring-orm" version="3.2.8.RELEASE" ...>
>   <feature version="3.2.8.RELEASE">spring</feature>
>   ...
> </feature>
> {code}
> To prepare the new "OSGi-like" feature resolver and be aligned with the Spring bundles
import packages, it would be better to use a version range like "[3.2.8.RELEASE,3.3)".
> The same policy applies for all Spring versions: [major.minor.micro, major.minor+1).



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message