karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Updated] (KARAF-2725) jpa feature should install org.osgi.enterprise 5.0.0 bundle
Date Tue, 08 Apr 2014 15:52:34 GMT

     [ https://issues.apache.org/jira/browse/KARAF-2725?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated KARAF-2725:
----------------------------------------

    Fix Version/s:     (was: 3.0.1)
                   3.0.2
                   4.0.0

> jpa feature should install org.osgi.enterprise 5.0.0 bundle
> -----------------------------------------------------------
>
>                 Key: KARAF-2725
>                 URL: https://issues.apache.org/jira/browse/KARAF-2725
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.0, 3.0.2
>
>
> The aries-jpa-container requires the org.osgi.service.jdbc package.
> With OSGi 4.3.0, the org.osgi.service.jdbc package is in compendium.
> But with OSGi 5.0.0, it's now in enterprise.
> So, the jpa feature should install the org.osgi.enterprise 5.0.0 bundle in order to get
the org.osgi.service.jdbc package.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message