karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-2725) jpa feature should install org.osgi.enterprise 5.0.0 bundle
Date Fri, 24 Jan 2014 05:52:37 GMT

    [ https://issues.apache.org/jira/browse/KARAF-2725?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13880740#comment-13880740
] 

Jean-Baptiste Onofré commented on KARAF-2725:
---------------------------------------------

Installation of the org.osgi.enterprise bundle causes issue with the datasource (extender).

For now, I revert my change in order to investigate.

> jpa feature should install org.osgi.enterprise 5.0.0 bundle
> -----------------------------------------------------------
>
>                 Key: KARAF-2725
>                 URL: https://issues.apache.org/jira/browse/KARAF-2725
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 3.0.1
>
>
> The aries-jpa-container requires the org.osgi.service.jdbc package.
> With OSGi 4.3.0, the org.osgi.service.jdbc package is in compendium.
> But with OSGi 5.0.0, it's now in enterprise.
> So, the jpa feature should install the org.osgi.enterprise 5.0.0 bundle in order to get
the org.osgi.service.jdbc package.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message