karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Watson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-2668) EIK fails to create Karaf project with Eclipse Kepler
Date Tue, 07 Jan 2014 09:55:51 GMT

    [ https://issues.apache.org/jira/browse/KARAF-2668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13864048#comment-13864048
] 

Simon Watson commented on KARAF-2668:
-------------------------------------

Thanks for clarifying. I just tried creating a new Karaf install project in Eclipse (Version:
Kepler Service Release 1
Build id: 20130919-0819), pointing at an installation of Karaf 2.3.1 and I get the same error:

Errors occurred during the build.
Errors running builder 'Apache Karaf Builder' on project 'Karaf Test'.
org/eclipse/pde/internal/core/target/provisional/ITargetPlatformService

So, is it the case that EIK only works with Karaf 2.x and Juno for now? 

As before, it would be very helpful to hear your thoughts on when EIK will work with the latest
Eclipse and Karaf builds. I notice that JIRA KARAF-2665 includes a patch for EIK on 4.3.1
although, when I tried to apply it, the file layout didn't seem to match the current git branch
- I figured this is either due to my lack of experience with the EIK source code or that things
changed from SVN -> Git?

> EIK fails to create Karaf project with Eclipse Kepler
> -----------------------------------------------------
>
>                 Key: KARAF-2668
>                 URL: https://issues.apache.org/jira/browse/KARAF-2668
>             Project: Karaf
>          Issue Type: Bug
>          Components: eik-core
>    Affects Versions: eik-0.10.0
>         Environment: OS X 10.9 (mavericks), Eclipse 4.3, 4.2
>            Reporter: Simon Watson
>            Assignee: Jean-Baptiste Onofré
>         Attachments: Screen Shot 2014-01-03 at 17.40.07.png
>
>
> I'm trying to get EIK to work with Eclipse IDE 4.3 and Karaf 3.0.0. I've cloned the git
repo and built from both the master and juno branches (this creates a 10.0-SNAPSHOT version).
I can install EIK, specify Apache Karaf as the OSGi framework and open the Karaf perspective
ok. But, when I try and create a new Karaf project, an error occurs (see attached screenshot).
> Is this a known issue? I realise you've been busy getting Karaf 3 out of the door but
it would be really helpful to know if a fix is needed or being worked on. Thanks!



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message