karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Resolved] (KARAF-2655) karaf-maven-plugin missing default feature descriptors
Date Wed, 25 Dec 2013 18:04:50 GMT

     [ https://issues.apache.org/jira/browse/KARAF-2655?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré resolved KARAF-2655.
-----------------------------------------

    Resolution: Won't Fix
      Assignee: Jean-Baptiste Onofré

It's the expected behavior: previously, we implicitely included all Karaf descriptors.
To be able to use different Karaf version with different Maven plugin version, now, we remove
the Karaf descriptors by default, and the users have to explicitely define the list of Karaf
features descriptor.

> karaf-maven-plugin missing default feature descriptors
> ------------------------------------------------------
>
>                 Key: KARAF-2655
>                 URL: https://issues.apache.org/jira/browse/KARAF-2655
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Amichai Rothman
>            Assignee: Jean-Baptiste Onofré
>            Priority: Minor
>
> The karaf-maven-plugin's features-add-to-repository [documentation|http://karaf.apache.org/manual/latest/developers-guide/karaf-maven-plugin-features-add-to-repository.html]
states that
> {quote}
> By default, the Karaf core features descriptors (standard and enterprise) are automatically
included in the descriptors set.
> {quote}
> However, adding e.g. the "scr" standard feature doesn't work (it can't find the feature)
unless the standard feature url is explicitly specified, i.e.
> {quote}
> {noformat}
> <descriptor>mvn:org.apache.karaf.features/standard/${karaf.version}/xml/features</descriptor>
> {noformat}
> {quote}
> So either the documentation is wrong (in which case it would be nice to have it mention
all the built-in feature urls one can choose from) or there is a regression bug (it worked
ok in the 2.3.3 equivalent plugin.)
> In addition, the "spring" feature no longer works without an explicit reference to the
spring descriptor url (this worked ok in the older plugin as well, and in 3.0.0 it doesn't
work even if the standard/enterprise feature descriptors are configured explicitly). This
should also either be mentioned in docs, or added to defaults for backwards compatibility.
> Finally, the example pom in the same documentation page is not up to date either regarding
both of these issues. It should be corrected to reflect a working example with consistent
configuration.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message