karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hans Loven (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KARAF-2641) User bundles do not start when using karaf client to install the encapsulating feature
Date Thu, 19 Dec 2013 17:40:09 GMT

     [ https://issues.apache.org/jira/browse/KARAF-2641?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hans Loven updated KARAF-2641:
------------------------------

    Environment: (64-bit) Ubuntu 12.04.3 LTS, openjdk-7  (was: Ubuntu 12.04.3 LTS, openjdk-7)

> User bundles do not start when using karaf client to install the encapsulating feature
> --------------------------------------------------------------------------------------
>
>                 Key: KARAF-2641
>                 URL: https://issues.apache.org/jira/browse/KARAF-2641
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.3.3
>         Environment: (64-bit) Ubuntu 12.04.3 LTS, openjdk-7
>            Reporter: Hans Loven
>              Labels: client, features
>
> I'm trying to script a "clean system restart," wherein I have a loop that uses the karaf
client to remotely install features.  However, after executing the script and connecting to
any remote karaf instance and then executing a "list" command, I see that all expected bundles
have been installed, but none have started.
> -As far as I can tell, the only way to recover from this state is to manually ssh out
to each hosting machine, shutdown karaf, blow away the data directory, restart karaf, and
install the feature.-
> WORKAROUND: actually, I wasn't patient enough -- restarting each karaf instance does
successfully start all user bundles -- but that of course adds significant time to my system
restart process...  



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message