karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Whyte (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-2561) When starting karaf under JDK 1.8 Early Access, karaf will not start
Date Sat, 09 Nov 2013 21:04:17 GMT

    [ https://issues.apache.org/jira/browse/KARAF-2561?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13818270#comment-13818270
] 

Steven Whyte commented on KARAF-2561:
-------------------------------------

Achim, I created KARAF-2562 for the NullPointerException.

> When starting karaf under JDK 1.8 Early Access, karaf will not start
> --------------------------------------------------------------------
>
>                 Key: KARAF-2561
>                 URL: https://issues.apache.org/jira/browse/KARAF-2561
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>    Affects Versions: 3.0.0.RC1
>         Environment: ARM Linux
>            Reporter: Steven Whyte
>             Fix For: 3.0.0
>
>
> When starting karaf the checkJvmVersion() function in bin/karaf fails looking at the
java version due to the early access has 1.8.0-ea and fails the egrep expression : 
> VERSION=`$JAVA -version 2>&1 | egrep '"([0-9].[0-9]\..*[0-9])"' | awk '{print
substr($3,2,length($3)-2)}' | awk '{print substr($1, 3, 3)}' | sed -e 's;\.;;g'`.
> Changing the statement to the following fixes the issue:
> VERSION=`$JAVA -version 2>&1 | egrep '"([0-9].[0-9]\..*[0-9ea])"' | awk '{print
substr($3,2,length($3)-2)}' | awk '{print substr($1, 3, 3)}' | sed -e 's;\.;;g'`



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message