karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrei Pozolotin (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-2180) feature update failure
Date Tue, 12 Feb 2013 14:09:14 GMT
Andrei Pozolotin created KARAF-2180:
---------------------------------------

             Summary: feature update failure
                 Key: KARAF-2180
                 URL: https://issues.apache.org/jira/browse/KARAF-2180
             Project: Karaf
          Issue Type: Bug
          Components: karaf-feature
            Reporter: Andrei Pozolotin


the following used to work in the past, but is broken in current trunk

use case:

prerequisite fetaure-1.xml:
* contains one bundle
* have same version for feature and bundle 1.0.0-SNAPSHOT

prerequisite fetaure-2.xml:
* contains same bundle, updated version
* have same version for feature and bundle 1.0.1-SNAPSHOT

actions:

1) auto-install feature-1.xml via drop into etc/feature.xml
* verify both feature and bundle are installed of v 1.0.0-SNAPSHOT
* only feature-1/bundle-1 are present

2) auto-install feature-2.xml via drop into the same etc/feature.xml
* verify both feature and bundle are installed of v 1.0.1-SNAPSHOT
* only feature-2/bundle-2 are present, and feature-1/bundle-1 is gone

current result (failure condition):
* both feature-1/bundle-1 and feature-2/bundle-2 are installed.

here is the test
https://github.com/barchart/barchart-service/blob/master/barchart-karaf-base-verify/src/test/java/com/barchart/karaf/test/ChangeVersionTest.java


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message