karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-2147) Upgrade to Aries JMX 1.1.0
Date Wed, 30 Jan 2013 14:51:12 GMT

    [ https://issues.apache.org/jira/browse/KARAF-2147?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13566515#comment-13566515
] 

Jean-Baptiste Onofré commented on KARAF-2147:
---------------------------------------------

Unfortunately, Aries JMX use "restrictive" version range for org.osgi.framework, which provide:

Bundle org.apache.aries.jmx.core [65] Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.core/1.1.0
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core
[65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.core
[65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
                
> Upgrade to Aries JMX 1.1.0
> --------------------------
>
>                 Key: KARAF-2147
>                 URL: https://issues.apache.org/jira/browse/KARAF-2147
>             Project: Karaf
>          Issue Type: Dependency upgrade
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.3.1, 3.0.0
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message