karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jamie goodyear (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (KARAF-1585) Installing using wrap protocol fails when specifying bundle version
Date Mon, 17 Dec 2012 10:46:31 GMT

     [ https://issues.apache.org/jira/browse/KARAF-1585?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jamie goodyear closed KARAF-1585.
---------------------------------

    
> Installing using wrap protocol fails when specifying bundle version
> -------------------------------------------------------------------
>
>                 Key: KARAF-1585
>                 URL: https://issues.apache.org/jira/browse/KARAF-1585
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.2.7
>            Reporter: Claus Ibsen
>            Assignee: Freeman Fang
>            Priority: Minor
>             Fix For: 2.2.9, 2.3.0, 3.0.0
>
>
> I follow the docs at
> http://karaf.apache.org/manual/2.2.7/developers-guide/creating-bundles.html
> at the section _Creating bundles for third party dependencies_
> I try to execute as documented
> {code}
> karaf@root> osgi:install wrap:mvn:commons-lang/commons-lang/2.4,Bundle-SymbolicName=commons-lang&Bundle-Version=2.4
> java.net.MalformedURLException: no protocol: Bundle-SymbolicName=commons-lang&Bundle-Version=2.4
> {code}
> But it fails. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message