karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerd Bremer (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (KARAF-1911) Wrong version of camel-example-osgi in Getting Started/Quickstart Guide - 2.7.0 doesn't work
Date Thu, 22 Nov 2012 09:56:58 GMT

    [ https://issues.apache.org/jira/browse/KARAF-1911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13502674#comment-13502674
] 

Gerd Bremer edited comment on KARAF-1911 at 11/22/12 9:56 AM:
--------------------------------------------------------------

Did you really fix it? I just quick started and failed with version 2.7.0. Using 2.10.2 works
fine.

Update: 
The 'Getting Started' link on the home page http://karaf.apache.org/ points to 

http://karaf.apache.org/manual/latest-2.2.x/quick-start.html

and not to

http://karaf.apache.org/manual/latest-2.3.x/quick-start.html

where the version is replaced. Maybe the link on the home page should be replaced?
                
      was (Author: gerbre1):
    Did you really fix it? I just quick started and failed with version 2.7.0. Using 2.10.2
works fine.
                  
> Wrong version of camel-example-osgi in Getting Started/Quickstart Guide - 2.7.0 doesn't
work
> --------------------------------------------------------------------------------------------
>
>                 Key: KARAF-1911
>                 URL: https://issues.apache.org/jira/browse/KARAF-1911
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-documentation
>    Affects Versions: 2.2.9
>         Environment: OpenJDK 1.6.0_24
>            Reporter: Robert Balent
>            Assignee: Freeman Fang
>             Fix For: 2.2.10, 2.3.0
>
>
> I've just downloaded Apache Karaf 2.2.9 for linux and proceeded through Quick Start guide.
> I've typed:
> features:addurl mvn:org.apache.camel/camel-example-osgi/2.7.0/xml/features
> features:install camel-example-osgi
> And error is:
> Error executing command: Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0
in feature(s) camel-spring-2.7.0: Uses constraint violation. Unable to resolve module org.apache.camel.camel-spring
\[79.0\] because it is exposed to package 'org.springframework.core' from modules org.springframework.core
\[51.0\] and org.springframework.core \[65.0\] via two dependency chains.
> Chain 1:
>   org.apache.camel.camel-spring \[79.0\]
>     import: (&(package=org.springframework.core)(version>=3.0.0)(!(version>=4.0.0)))
>      |
>     export: package=org.springframework.core
>   org.springframework.core \[51.0\]
> Chain 2:
>   org.apache.camel.camel-spring \[79.0\]
>     import: (&(package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))
>      |
>     export: package=org.springframework.osgi.context; uses:=org.springframework.beans
>   org.springframework.osgi.core \[74.0\]
>     import: (&(package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))
>      |
>     export: package=org.springframework.beans; uses:=org.springframework.core
>   org.springframework.beans \[68.0\]
>     import: (&(package=org.springframework.core)(version>=3.0.7)(!(version>=3.0.8)))
>      |
>     export: package=org.springframework.core
>   org.springframework.core \[65.0\]
> It works with camel-example-osgi:2.6.0 version.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message