karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Don Corley (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-1937) Cave broken in karaf 2.3.0
Date Wed, 17 Oct 2012 17:16:03 GMT
Don Corley created KARAF-1937:
---------------------------------

             Summary: Cave broken in karaf 2.3.0
                 Key: KARAF-1937
                 URL: https://issues.apache.org/jira/browse/KARAF-1937
             Project: Karaf
          Issue Type: Bug
          Components: cave-server
    Affects Versions: 3.0.0
         Environment: All
            Reporter: Don Corley


Karaf cave crashes in the current version of karaf 2.3.0:
> features:addurl mvn:org.apache.karaf.cave/apache-karaf-cave/3.0.0-SNAPSHOT/xml/features
> features:install cave-obr-server
org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to intialize bean
cxf

Fix:
Just update the dependencies:
---start patch---
Index: pom.xml
===================================================================
--- pom.xml	(revision 1399329)
+++ pom.xml	(working copy)
@@ -24,7 +24,7 @@
     <parent>
         <groupId>org.apache</groupId>
         <artifactId>apache</artifactId>
-        <version>10</version>
+        <version>11</version>
     </parent>
 
     <groupId>org.apache.karaf</groupId>
@@ -34,12 +34,12 @@
     <name>Apache Karaf :: Cave</name>
 
     <properties>
-        <commons-io.version>2.0.1</commons-io.version>
-        <cxf.version>2.4.3</cxf.version>
+        <commons-io.version>2.4</commons-io.version>
+        <cxf.version>2.7.0</cxf.version>
         <felix.bundlerepository.version>1.6.6</felix.bundlerepository.version>
-        <httpclient.version>4.1.1</httpclient.version>
-        <jsoup.version>1.6.1</jsoup.version>
-        <karaf.version>2.2.4</karaf.version>
+        <httpclient.version>4.2.1</httpclient.version>
+        <jsoup.version>1.7.1</jsoup.version>
+        <karaf.version>2.3.0</karaf.version>
         <osgi.version>4.2.0</osgi.version>
         <wagon.version>1.0</wagon.version>
     </properties>
@@ -92,7 +92,7 @@
             <dependency>
                 <groupId>org.slf4j</groupId>
                 <artifactId>slf4j-api</artifactId>
-                <version>1.6.1</version>
+                <version>1.7.2</version>
             </dependency>
         </dependencies>
     </dependencyManagement>
@@ -104,19 +104,19 @@
         <dependency>
             <groupId>junit</groupId>
             <artifactId>junit</artifactId>
-            <version>4.7</version>
+            <version>4.10</version>
             <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>org.slf4j</groupId>
             <artifactId>slf4j-log4j12</artifactId>
-            <version>1.6.1</version>
+            <version>1.7.2</version>
             <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>log4j</groupId>
             <artifactId>log4j</artifactId>
-            <version>1.2.16</version>
+            <version>1.2.17</version>
             <scope>test</scope>
         </dependency>
     </dependencies>
---end patch---
I love cave!
Thanks,
Don

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message