karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jamie goodyear (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KARAF-1906) Compile error using IBM JDK on JAAS module.
Date Wed, 10 Oct 2012 12:57:02 GMT

     [ https://issues.apache.org/jira/browse/KARAF-1906?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jamie goodyear resolved KARAF-1906.
-----------------------------------

    Resolution: Fixed

Added explicit casts for IBM JDK compatibility.

$ svn ci
Sending        jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesBackingEngine.java
Sending        jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesLoginModule.java
Sending        jaas/modules/src/main/java/org/apache/karaf/jaas/modules/publickey/PublickeyLoginModule.java
Transmitting file data ...
Committed revision 1396578.
                
> Compile error using IBM JDK on JAAS module.
> -------------------------------------------
>
>                 Key: KARAF-1906
>                 URL: https://issues.apache.org/jira/browse/KARAF-1906
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>    Affects Versions: 2.3.0
>            Reporter: Jamie goodyear
>            Assignee: Jamie goodyear
>            Priority: Blocker
>             Fix For: 2.3.0
>
>
> Build 2.3.0-SNAPSHOT with IBM JDK, will observe compile errors:
> {code}
> [INFO] Compilation failure
> /x1/karaf/karaf-2.3.x/jaas/modules/src/main/java/org/apache/karaf/jaas/modules/publickey/PublickeyLoginModule.java:[95,33]
error: incompatible types
>   required: String
>   found:    Object
> /x1/karaf/karaf-2.3.x/jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesBackingEngine.java:[73,36]
error: incompatible types
>   required: String
>   found:    Object
> /x1/karaf/karaf-2.3.x/jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesBackingEngine.java:[120,44]
error: incompatible types
>   required: String
>   found:    Object
> /x1/karaf/karaf-2.3.x/jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesBackingEngine.java:[135,35]
error: incompatible types
>   required: String
>   found:    Object
> /x1/karaf/karaf-2.3.x/jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesBackingEngine.java:[150,36]
error: incompatible types
>   required: String
>   found:    Object
> /x1/karaf/karaf-2.3.x/jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesBackingEngine.java:[172,36]
error: incompatible types
>   required: String
>   found:    Object
> /x1/karaf/karaf-2.3.x/jaas/modules/src/main/java/org/apache/karaf/jaas/modules/properties/PropertiesLoginModule.java:[86,33]
error: incompatible types
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message